Heel soms geen toetsenbord en muis

Allerhande Hardware vragen
Gebruikersavatar
nahjo
Senior
Senior
Berichten: 281
Lid geworden op: Vr 23 Okt 2015, 12:45

Heel soms geen toetsenbord en muis

Berichtdoor nahjo » Vr 30 Okt 2015, 20:06

Hallo forum,
heel af en toe heb ik het probleem dat toetsenbord en muis niet werken op mijn notebook, maar het externe beeldscherm werkt goed.
Ik heb een Dell D520 notebook in een docking-station aan een KVM switch gekoppeld. Op de KVM switch zijn naast een PC (beetje logisch), een PS/2 toetsenbord, PS/2 muis en een beeldscherm aangesloten.

Ik heb mij inmiddels al aangeleerd om tijdens het opstarten van de notebook er voor te zorgen dat er verbinding is met het beeldscherm en de muis te bewegen in de veronderstelling dat hierdoor de PS/2 aansluiting herkend kan worden door het systeem. Bij de PC is dit bewegen van de muis of verbinding met het scherm niet nodig omdat toetsenbord en muis op de PC altijd werken.
Zowel notebook als PC draaien met 17.2 xfce.

Mijn opstart cyclus is nu: start de notebook op en beweeg de muis net zolang tot die ook op het beeldscherm actief is en start pas dan de PC op. Als ik dit doe heb ik geen problemen met toetsenbord en muis.

Is mijn veronderstelling correct dat bij het opstarten van de notebook het systeem niet de PS/2 apparaten kan herkennen (als daar geen activiteit van is) vanwege het docking-station?
En is er een mogelijkheid om dat hardware testen te vervangen door een 'laatst goed werkende' configuratie instelling?
Tips en zoekrichtingen zijn van harte welkom.
Gebruikersavatar
nahjo
Senior
Senior
Berichten: 281
Lid geworden op: Vr 23 Okt 2015, 12:45

Re: Heel soms geen toetsenbord en muis

Berichtdoor nahjo » Zo 15 Nov 2015, 11:00

Heb het 'probleem' een beetje kunnen lokaliseren.
Bij de eerste koude start na een linux update is er geen reactie van toetsenbord en muis maar wel beeld. Na opnieuw opstarten werken toetsenbord en muis ook weer.
Nu ik het weet kan ik er mee leven ;)
Wilfried1954
Algemene moderator
Algemene moderator
Berichten: 811
Lid geworden op: Ma 08 Dec 2014, 11:26
Contact:

Re: Heel soms geen toetsenbord en muis

Berichtdoor Wilfried1954 » Zo 15 Nov 2015, 11:15

Een mogelijke hypothese is dat bij een koude start - op het ogenblik dat het operating systeem de drivers voor toetsenbord en muis probeert te installeren - er nog geen toetsenbord en muis 'aanwezig' is. Dus dat de hardware nog niet werkt op dat ogenblik. Bij herstarten is dat dan natuurlijk wel in orde.

Om deze hypothese te toetsen zou je eens kunnen proberen kort na het opstarten - nog voor Linux start - op de pauze toets te tikken. En na een korte tijd terug zodat het systeem verder start. Een andere mogelijkheid is te herstarten vlak na de koude start onmiddellijk na de POST ctrl-alt-del. Nog een mogelijkheid is de BIOS enteren, even wachten en daarna verder gaan zonder te herstarten (zo is er ook een vertraging).

Als deze hypothese correct is blijft natuurlijk de vraag hoe te verhelpen. Een kleine vertraging voor het opstarten van Linux inbouwen zal wel mogelijk zijn.
Linux Mint 17.1 en 18.1 Mate 64 bit
Gebruikersavatar
nahjo
Senior
Senior
Berichten: 281
Lid geworden op: Vr 23 Okt 2015, 12:45

Re: Heel soms geen toetsenbord en muis

Berichtdoor nahjo » Zo 15 Nov 2015, 13:04

Dank voor het meedenken Wilfried1954.
Het probleem zit waarschijnlijk in de configuratie notebook+docking+kvm+ps/2 apparaten. Ik had zelf het idee om na een linux update de notebook tijdelijk uit de docking te halen en dan te starten. maar zal nu eerst het onderbreken van het opstarten eens proberen.
Heb het nu wat meer onder controle na het verwijderen van 'unattend-upgrades' ::)
Gebruikersavatar
Joan
LMNLVip
LMNLVip
Berichten: 1615
Lid geworden op: Do 16 Feb 2012, 00:49
Contact:

Re: Heel soms geen toetsenbord en muis

Berichtdoor Joan » Wo 26 Apr 2017, 18:28

Ps/2 zal niet werken als het niet bij opstart is aangesloten. Kun je de KVM via usb aan het notebook aansluiten?
Kijk eens in de bios van het notebook of je de opstartvolgorde kunt aanpassen.
Mint 18.2 Cinnamon 64bit , werk. Mint 17.3 Cinnamon 64bit , archief.
LMDE op laptop en RasberyPy met Debian, soms.
Gebruikersavatar
nahjo
Senior
Senior
Berichten: 281
Lid geworden op: Vr 23 Okt 2015, 12:45

Re: Heel soms geen toetsenbord en muis

Berichtdoor nahjo » Do 27 Apr 2017, 07:58

Hoi Joan,
De KVM switch (Eminent EM1033) is blijkbaar zo inteligent dat het seintje aan de computer geeft ik ben PS2 :)
Soms (minder dan voorheen) gebeurde het nog wel eens dat muis en toetsenbord op de notebook niet werkten. Met de aanpassing in GRUB is het even afwachten of 'soms' in 'nooit meer' gaat wijzigen.
De aanpassing in GRUB:

Code: Selecteer alles

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash atkbd.reset"

Terug naar “Hardware en Drivers”

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers en 1 gast