digikam ppa

Fotografie en grafische bewerking
Wilu
Nieuweling
Nieuweling
Berichten: 4
Lid geworden op: Za 05 Dec 2015, 14:39

digikam ppa

Berichtdoor Wilu » Za 05 Dec 2015, 15:55

Hallo ik gebruik Mint 17,2 Cinnamon 32 bit en Mint 17,2 KDE 64 bit. M.b.v. de ppa's kan ik nieuwe versies van Krita Darktable enz. prima installeren. De ppa van Philip5/extra en ook die van Philip5/kubuntu-backports laten Digikam 4,14 niet zien in de lijst die zichtbaar wordt als je de ppa opent in de softwarebronnen. Op Lanchpad is deze wel zichtbaar. Blijkbaar worden deze door Mint zelf geblokkeerd? Wie kan mij vertellen wat de reden hiervoor is, wat moet ik doen om Digikam 4,14 wel te installeren. Of is dit zeer onverstandig? Ubuntu en Open Suse installeren Digikam 4,14 wel maar ik vind Mint leuker en prettiger.
Gr. Wilu.
Gebruikersavatar
Joan
LMNLVip
LMNLVip
Berichten: 1637
Lid geworden op: Do 16 Feb 2012, 00:49
Contact:

Re: digikam ppa

Berichtdoor Joan » Za 05 Dec 2015, 20:45

Wat de reden is dat de een wel iets doet en de ander niet kan ik je niet vertellen en er naar gissen heeft geen zin.
Als je iets in Ubuntu kan installeren moet het bijna zeker mogelijk zijn om het ook in Mint te doen.
Alles programma's die je via Softwarebeheer installeert zijn gecontroleerd en veilig en zou geen problemen moeten geven in Mint.

Kijk eens of Digikam 14.0.4 in Softwarebeheer van Mint aan je wensen voldoet.
Wat ook nog kan is de ppa-instelling in Softwarebeheer aanpassen.
Anders kun je de ppa of een .deb file op internet zoeken en die installeren.
eenvoudig
Mint 18.2 Cinnamon 64bit , werk. Mint 17.3 Cinnamon 64bit , archief.
LMDE op laptop en RasberyPy met Debian, soms.
Wilu
Nieuweling
Nieuweling
Berichten: 4
Lid geworden op: Za 05 Dec 2015, 14:39

Re: digikam ppa

Berichtdoor Wilu » Zo 06 Dec 2015, 13:03

Hallo Joan,
Het gaat mij om de installatie van Digikam 4:4.14.0. Dit zou moeten kunnen met de ppa van Philip Jonsson op lanchpad. In Ubuntu gaat het goed in Mint lukt het mij niet. Dit is wat Philip er zelf over zegt in antwoord op een vraag van Antonio op :

http://digikam.1695700.n4.nabble.com/Qu ... 78589.html

Yes you can but that is a Linux Mint problem and not a Ubuntu problem. Linux Mint use Pin-Priority to lock out what it considers unstable or experimental packages sources. This is used in Debian too to hold back packages in stable from installing packages from Debian unstable or experimental. Ubuntu work a bit different with its release cycles. Why Linux Mint do as it does I don't know as it's based on Ubuntu otherwise and I'm not that used to changing Pin-Priority and Launchpad sources are listed as 500.

I haven't tried it as I don't have to but try to install digikam with apt-get and the -t unstable parameter; "sudo apt-get -t unstable install digikam". That might work on Linux Mint and works on Debian if you want install some special package from Debian unstable on Debian stable and dependecies. If that doesn't work I think you have to ask in the Linux Mint community how they handled package sources with higher Pin-Priority.

Hope that helps.

Philip

De sudo code "sudo apt-get -t unstable install digikam" werkt niet en ik kan op internet niet vinden hoe Pin-Prioryty veranderd kan worden, laat staan dat mij bekend is welke risico's ik dan daarbij neem.
Misschien is mijn vraag nu iets duidelijker?
Gebruikersavatar
Joan
LMNLVip
LMNLVip
Berichten: 1637
Lid geworden op: Do 16 Feb 2012, 00:49
Contact:

Re: digikam ppa

Berichtdoor Joan » Zo 06 Dec 2015, 15:42

Je hebt het al gezien "sudo apt-get -t unstable install digikam" UNSTABLE. Dit betekend dat het niet overal werkt en er systeem fouten kunnen ontstaan.
Als je niet weet wat een terminal-commando doet moet je erg voorzichtig zijn, vooral met sudo. De handleiding van apt-get kun je in de terminal lezen met het commando: man apt-get

Het is met onstabiele onderdelen alleen mogelijk om op jouw eigen systeem naar oplossingen te zoeken omdat het apparaat-bugs kunnen zijn of de aanroep van bibliotheken die er niet zijn.
Deze ppa is ook een particuliere ppa die niet door de Mint gemeenschap is gecontroleerd of als veilig wordt beschouwd. Gebruik nog meer op eigen risico.
Ubuntu werkt wat anders met toekennen van externe onderdelen.

Het programma is wel aangepast voor de KDE desktop en niet direct voor Cinnamon. daarvoor moet Cinnamon mogelijk worden bijgewerkt. Dit gebeurt zeker al (voor een deel) bij instal via Softwarebeheer.
Bij de commentaren van Digikam in Softwarebeheer kun je daarover ook het een en ander lezen.

Wat ik in zo'n situatie vaak doe is:
Installeer het programma uit Softwarebeheer, want dat is altijd veilig.
Daarna kunnen verschillende mogelijkheden ontstaan.
1. Kijk of met het programma kan worden ge-update naar een nieuwere versie.
2. Er kunnen in Softwarebeheer aanvullingen worden aangeboden.
3. Je kunt in Synaptic zoeken naar updates of aanvullingen. Dit is niet simpel als je niet weet wat je moet installeren.
4. Kijk in Updatebeheer of de ppa's kunnen worden ingesteld. Houdt hierbij wel rekening met z'n KDE behoefte.
5. Je kunt de ppa's via de terminal installeren. Hiermee kan de situatie ontstaan dat het verder moet worden aangepast en daarvoor is geen standaard methode voor te geven.

Tip: Pas altijd op met ppa's die niet in de Mint repository worden aangeboden, vooral met apparatuur gebonden onderdelen of bibliotheken. Deze en andere onstabiele versies kunnen voor onvoorziene problemen zorgen, zoals je in de commenteren van digikam al kunt lezen.

Ik kan niet het risico lopen dat mijn systeem onstabiel wordt door onveilige installaties dus kan het niet uitproberen.
Mint 18.2 Cinnamon 64bit , werk. Mint 17.3 Cinnamon 64bit , archief.
LMDE op laptop en RasberyPy met Debian, soms.
Gebruikersavatar
Joan
LMNLVip
LMNLVip
Berichten: 1637
Lid geworden op: Do 16 Feb 2012, 00:49
Contact:

Re: digikam ppa

Berichtdoor Joan » Zo 06 Dec 2015, 15:57

Hier nog de link hoe je een oplossing kan zoeken.
http://digikam.1695700.n4.nabble.com/Ca ... l#a4681442
Mint 18.2 Cinnamon 64bit , werk. Mint 17.3 Cinnamon 64bit , archief.
LMDE op laptop en RasberyPy met Debian, soms.
Wilu
Nieuweling
Nieuweling
Berichten: 4
Lid geworden op: Za 05 Dec 2015, 14:39

Re: digikam ppa

Berichtdoor Wilu » Ma 07 Dec 2015, 16:35

Dank je wel Joan, ik ga verder puzzelen. Als het fout gaat geeft het niet ik probeer alles eerst uit op een aparte pc.
Gebruikersavatar
Leon
Senior
Senior
Berichten: 217
Lid geworden op: Vr 21 Nov 2014, 09:12

Re: digikam ppa

Berichtdoor Leon » Di 08 Dec 2015, 03:24

Hier staat hoe je de pin priority kan aanpassen
http://forums.linuxmint.com/viewtopic.php?f=47&t=201522
LMDE 2 MATE x64

Terug naar “Fotografie”

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers en 1 gast