Afsluiten en starten duurt erg lang na bijwerken pakketten

Vragen over Grub, de liveCD en de installer
TSchevan
Nieuweling
Nieuweling
Berichten: 6
Lid geworden op: Zo 21 Aug 2016, 11:17

Afsluiten en starten duurt erg lang na bijwerken pakketten

Berichtdoor TSchevan » Ma 22 Aug 2016, 22:50

Hallo, eerste bericht van een nieuw forumlid en nieuw Linux gebruiker. Sinds kort de trotse eigenaar/beheerder van een dual-boot systeem; Linux Mint Sarah en een ander (verder niet bij naam te noemen OS) versie 10.
Installatie ging niet vanzelf, maar met het nodige geGoogle en speurwerk ben ik toch een heel eind gekomen. Maar nu loop ik toch tegen een lastiger probleem aan.
Oorspronkelijk startte Linux vlot genoeg op. Ik heb het niet geklokt maar laten we zeggen 15 seconden. Echter, na het bijwerken van de pakketten (116 stuks, als ik het mij goed herinner) duurt het opstarten en afsluiten erg lang.
Opstarten ca. 50 seconden vanaf selectie in het Grub-menu tot verschijnen van de desktop (bij automatisch aanmelden als gewone gebruiker)
Afsluiten of Herstart ca. 80 seconden. Na 5-10 seconden schakelt het beeldscherm uit, maar daarna duurt het nog 80 seconden waarin niets lijkt te gebeuren.

De opdracht
systemd-analyze blame
levert wel dit op:

Code: Selecteer alles

         34.848s lvm2-monitor.service
          8.812s NetworkManager-wait-online.service
           380ms apt-daily.service
           271ms gpu-manager.service
           264ms dev-sda5.device
           190ms nmbd.service
           167ms samba-ad-dc.service
           132ms smbd.service
           130ms accounts-daemon.service
           121ms ModemManager.service
           105ms udisks2.service
           105ms networking.service

Vooral de eerste 2 posten springen eruit. Maar hoe, wat en waar ik dat bijstellen/corrigeren kan is voor mij nog even de grote vraag.
Desktop: Intel I5-4570 CPU @ 3.20GHz x 4. Ram 8G. Videokaart NVIDIA GTX 650 Ti Boost.
Dualboot Windows10 en Linux Mint Sarah Cinnamon 64-bit (3.0.7), beide op SSD 128G.
---------------------
"I'll rant as well as thou!" - Hamlet
Gebruikersavatar
Pjotr
Held
Held
Berichten: 352
Lid geworden op: Zo 03 Jan 2016, 15:44

Re: Afsluiten en starten duurt erg lang na bijwerken pakketten

Berichtdoor Pjotr » Di 23 Aug 2016, 00:13

Post hier eens een volledig systeemoverzicht, op de volgende wijze:
https://sites.google.com/site/computertip/inxi
Tip: doe deze 10 dingen direct na installatie van Linux Mint 18.2
Houd je Linux Mint gezond: vermijd deze 10 fatale vergissingen
Twitter: Linuxtip
Alles is te kraken, niets is geheel veilig, zorg dus voor zoveel mogelijk niets. (Ramana)
Gebruikersavatar
dirkjanl
Senior
Senior
Berichten: 197
Lid geworden op: Do 21 Mar 2013, 13:40
Locatie: Borger
Contact:

Re: Afsluiten en starten duurt erg lang na bijwerken pakketten

Berichtdoor dirkjanl » Di 23 Aug 2016, 16:36

Laat ik nou ook merken dat vooral het afsluiten erg vertraagd is sinds een paar dagen. Zo gemiddeld 1 minuut 35 seconden. Ging eerst echt veel sneller.
Ik ben zo vrij hier de printscreens te plaatsen met inxi van mijn PC met LinuxMint18.

Afbeelding

Afbeelding

Afbeelding

Afbeelding

Afbeelding
Laptop Clevo N240BU 14", HD Graphics 620, Intel i7-7500U, RAM 16GB, Linux Mint 18.2 Cinnamon-64 bit
Vaste PC Intel i7-6700, Nvidea Geoforce GT730 4 gb, 16 GB RAM, Asus B250M moederbord. Linux Mint 18.2 Cinnamon-64 bit
TSchevan
Nieuweling
Nieuweling
Berichten: 6
Lid geworden op: Zo 21 Aug 2016, 11:17

Re: Afsluiten en starten duurt erg lang na bijwerken pakketten

Berichtdoor TSchevan » Di 23 Aug 2016, 20:30

Nou, het helpt wellicht als anderen hetzelfde probleem hebben. Maar voorkruipen is een andere zaak ;)

Hier is mijn INXI overzicht:
Inxi -Fx

Code: Selecteer alles

Gebruiker ~ $ inxi -Fx
System:    Host: SallandLM Kernel: 4.4.0-21-generic x86_64 (64 bit gcc: 5.3.1)
           Desktop: Cinnamon 3.0.7 (Gtk 3.18.9-1ubuntu3.1) Distro: Linux Mint 18 Sarah
Machine:   System: Gigabyte product: Z87X-D3H
           Mobo: Gigabyte model: Z87X-D3H-CF v: x.x Bios: American Megatrends v: F7 date: 08/02/2013
CPU:       Quad core Intel Core i5-4570 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 25602
           clock speeds: max: 3600 MHz 1: 3553 MHz 2: 3315 MHz 3: 3598 MHz 4: 3588 MHz
Graphics:  Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GK106 [GeForce GTX 650 Ti Boost] bus-ID: 01:00.0
           Display Server: X.Org 1.18.3 drivers: nvidia,intel (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 650 Ti BOOST/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 361.42 Direct Rendering: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GK106 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Card-3 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
Network:   Card: Intel Ethernet Connection I217-V driver: e1000e v: 3.2.6-k port: f080 bus-ID: 00:19.0
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: 94:de:80:6e:e7:9c
Drives:    HDD Total Size: 1128.2GB (1.3% used) ID-1: /dev/sda model: Samsung_SSD_840 size: 128.0GB
           ID-2: /dev/sdb model: WDC_WD10EFRX size: 1000.2GB
Partition: ID-1: / size: 29G used: 6.8G (26%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 8.19GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:36C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 194 Uptime: 6 min Memory: 942.6/7873.2MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.421) inxi: 2.2.35
Gebruiker ~ $


inxi -Fxz

Code: Selecteer alles

Gebruiker ~ $ inxi -Fxz
System:    Host: SallandLM Kernel: 4.4.0-21-generic x86_64 (64 bit gcc: 5.3.1)
           Desktop: Cinnamon 3.0.7 (Gtk 3.18.9-1ubuntu3.1) Distro: Linux Mint 18 Sarah
Machine:   System: Gigabyte product: Z87X-D3H
           Mobo: Gigabyte model: Z87X-D3H-CF v: x.x Bios: American Megatrends v: F7 date: 08/02/2013
CPU:       Quad core Intel Core i5-4570 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 25602
           clock speeds: max: 3600 MHz 1: 3592 MHz 2: 3574 MHz 3: 3599 MHz 4: 3600 MHz
Graphics:  Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller bus-ID: 00:02.0
           Card-2: NVIDIA GK106 [GeForce GTX 650 Ti Boost] bus-ID: 01:00.0
           Display Server: X.Org 1.18.3 drivers: nvidia,intel (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: GeForce GTX 650 Ti BOOST/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 361.42 Direct Rendering: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GK106 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Card-3 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
Network:   Card: Intel Ethernet Connection I217-V driver: e1000e v: 3.2.6-k port: f080 bus-ID: 00:19.0
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1128.2GB (1.3% used) ID-1: /dev/sda model: Samsung_SSD_840 size: 128.0GB
           ID-2: /dev/sdb model: WDC_WD10EFRX size: 1000.2GB
Partition: ID-1: / size: 29G used: 6.8G (26%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 8.19GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:36C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 192 Uptime: 12 min Memory: 1003.4/7873.2MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.421) inxi: 2.2.35
Gebruiker ~ $


inxi -Sr

Code: Selecteer alles

Gebruiker ~ $ inxi -Sr
System:    Host: SallandLM Kernel: 4.4.0-21-generic x86_64 (64 bit) Desktop: Cinnamon 3.0.7
           Distro: Linux Mint 18 Sarah
Repos:     Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://ftp.nluug.nl/os/Linux/distr/linuxmint/packages sarah main upstream import backport
           deb http://mirror.nforce.com/pub/linux/ubuntu xenial main restricted universe multiverse
           deb http://mirror.nforce.com/pub/linux/ubuntu xenial-updates main restricted universe multiverse
           deb http://mirror.nforce.com/pub/linux/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
Gebruiker ~ $


inxi -Ax

Code: Selecteer alles

Gebruiker ~ $ inxi -Ax
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GK106 HDMI Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Card-3 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
Gebruiker ~ $


En tot slot: inxi -u

Code: Selecteer alles

Gebruiker ~ $ inxi -u
Partition: ID-1: / size: 29G used: 6.8G (26%) fs: ext4 dev: /dev/sda5 uuid: 1b604fb6-bcb7-411d-b679-4b00d723ddd5
           ID-2: swap-1 size: 8.19GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
           uuid: ac98b76d-6e7c-46a1-8ced-ae90b1542d70
Gebruiker ~ $


Hoop dat je er wat aan hebt.
Desktop: Intel I5-4570 CPU @ 3.20GHz x 4. Ram 8G. Videokaart NVIDIA GTX 650 Ti Boost.
Dualboot Windows10 en Linux Mint Sarah Cinnamon 64-bit (3.0.7), beide op SSD 128G.
---------------------
"I'll rant as well as thou!" - Hamlet
TSchevan
Nieuweling
Nieuweling
Berichten: 6
Lid geworden op: Zo 21 Aug 2016, 11:17

Re: Afsluiten en starten duurt erg lang na bijwerken pakketten

Berichtdoor TSchevan » Zo 28 Aug 2016, 20:49

Niemand een idee waar het probleem in zou kunnen zitten?
Desktop: Intel I5-4570 CPU @ 3.20GHz x 4. Ram 8G. Videokaart NVIDIA GTX 650 Ti Boost.
Dualboot Windows10 en Linux Mint Sarah Cinnamon 64-bit (3.0.7), beide op SSD 128G.
---------------------
"I'll rant as well as thou!" - Hamlet
Gebruikersavatar
dirkjanl
Senior
Senior
Berichten: 197
Lid geworden op: Do 21 Mar 2013, 13:40
Locatie: Borger
Contact:

Re: Afsluiten en starten duurt erg lang na bijwerken pakketten

Berichtdoor dirkjanl » Ma 29 Aug 2016, 11:03

Bij mij is het opgelost.
Vanaf zaterdag merk ik dat de PC veel sneller afsluit. Nu binnen de 10 seconden. Ik zelf heb eigenlijk niets meer gedaan dan gewoonlijk: een programma gedownload, een programma verwijderd, gewoon gewerkt met de diverse programma's en gewoon de updates uitgevoerd.
Ik zal vanavond eens gaan vergelijken met de printscreens van hierboven.

Groet, Dirk Jan
Laptop Clevo N240BU 14", HD Graphics 620, Intel i7-7500U, RAM 16GB, Linux Mint 18.2 Cinnamon-64 bit
Vaste PC Intel i7-6700, Nvidea Geoforce GT730 4 gb, 16 GB RAM, Asus B250M moederbord. Linux Mint 18.2 Cinnamon-64 bit
TSchevan
Nieuweling
Nieuweling
Berichten: 6
Lid geworden op: Zo 21 Aug 2016, 11:17

Re: Afsluiten en starten duurt erg lang na bijwerken pakketten

Berichtdoor TSchevan » Vr 02 Sep 2016, 16:59

Wel, hier komen wij niet verder mee. En aangezien de lijst met problemen groeit, is dit dan ook weer einde avontuur Linux.
Gegroet.
Desktop: Intel I5-4570 CPU @ 3.20GHz x 4. Ram 8G. Videokaart NVIDIA GTX 650 Ti Boost.
Dualboot Windows10 en Linux Mint Sarah Cinnamon 64-bit (3.0.7), beide op SSD 128G.
---------------------
"I'll rant as well as thou!" - Hamlet
Gebruikersavatar
nahjo
Senior
Senior
Berichten: 291
Lid geworden op: Vr 23 Okt 2015, 12:45

Re: Afsluiten en starten duurt erg lang na bijwerken pakketten

Berichtdoor nahjo » Za 03 Sep 2016, 12:00

Het lang duren van afsluiten heb ik alleen na updates van Windows. Bij LM is het mij nog nooit opgevallen.
Gebruikersavatar
dirkjanl
Senior
Senior
Berichten: 197
Lid geworden op: Do 21 Mar 2013, 13:40
Locatie: Borger
Contact:

Re: Afsluiten en starten duurt erg lang na bijwerken pakketten

Berichtdoor dirkjanl » Za 03 Sep 2016, 20:52

Er waren wat issues als W10 en Linux op een schijf staan met dual boot. Misschien op zoeken?
Zelf heb ik gekozen voor 2 SSD stations, gewoon voor de zekerheid. 1 voor Windows 7 (de grote SSD) en 1 voor Linux (de kleine SSD).
Laptop Clevo N240BU 14", HD Graphics 620, Intel i7-7500U, RAM 16GB, Linux Mint 18.2 Cinnamon-64 bit
Vaste PC Intel i7-6700, Nvidea Geoforce GT730 4 gb, 16 GB RAM, Asus B250M moederbord. Linux Mint 18.2 Cinnamon-64 bit
nom001

Re: Afsluiten en starten duurt erg lang na bijwerken pakketten

Berichtdoor nom001 » Ma 05 Sep 2016, 11:05

TSchevan schreef:Wel, hier komen wij niet verder mee. En aangezien de lijst met problemen groeit, is dit dan ook weer einde avontuur Linux.
Gegroet.

Helaas heeft Linux nog steeds een bepaalde leercurve waar je even doorheen moet bijten. Gelijk opgeven is een teken van zwakte mijn inziens. Als je gewoon jouw problemen opsomt kunnen we je wellicht helpen.
Dummy
Senior
Senior
Berichten: 146
Lid geworden op: Di 19 Aug 2014, 22:31

Re: Afsluiten en starten duurt erg lang na bijwerken pakketten

Berichtdoor Dummy » Ma 05 Sep 2016, 17:14

dirkjanl schreef:Er waren wat issues als W10 en Linux op een schijf staan met dual boot. Misschien op zoeken?


Op mijn desktop had ik een Windows7 en Mint 17.2 in een dual boot zonder problemen. W10 over W7 geïnstalleerd en geen probleem ondervonden.
Als je Windows heb leren kennen ga je van Linux houden.
TSchevan
Nieuweling
Nieuweling
Berichten: 6
Lid geworden op: Zo 21 Aug 2016, 11:17

Re: Afsluiten en starten duurt erg lang na bijwerken pakketten

Berichtdoor TSchevan » Ma 05 Sep 2016, 21:41

nom001 schreef:Helaas heeft Linux nog steeds een bepaalde leercurve waar je even doorheen moet bijten. Gelijk opgeven is een teken van zwakte mijn inziens. Als je gewoon jouw problemen opsomt kunnen we je wellicht helpen.

Wel, deze zwakkeling had probleem 1 gewoon hierboven al beschreven.
Desktop: Intel I5-4570 CPU @ 3.20GHz x 4. Ram 8G. Videokaart NVIDIA GTX 650 Ti Boost.
Dualboot Windows10 en Linux Mint Sarah Cinnamon 64-bit (3.0.7), beide op SSD 128G.
---------------------
"I'll rant as well as thou!" - Hamlet
Wilfried1954
Algemene moderator
Algemene moderator
Berichten: 813
Lid geworden op: Ma 08 Dec 2014, 11:26
Contact:

Re: Afsluiten en starten duurt erg lang na bijwerken pakketten

Berichtdoor Wilfried1954 » Di 06 Sep 2016, 17:40

TSchevan schreef:
nom001 schreef:Helaas heeft Linux nog steeds een bepaalde leercurve waar je even doorheen moet bijten. Gelijk opgeven is een teken van zwakte mijn inziens. Als je gewoon jouw problemen opsomt kunnen we je wellicht helpen.

Wel, deze zwakkeling had probleem 1 gewoon hierboven al beschreven.


Het antwoord van Nom001 is vermoedelijk niet slecht bedoeld hoor, maar eerder als ondersteuning van wat door te bijten. We geraken er wel door.
Linux Mint 17.1 en 18.1 Mate 64 bit
TSchevan
Nieuweling
Nieuweling
Berichten: 6
Lid geworden op: Zo 21 Aug 2016, 11:17

Re: Afsluiten en starten duurt erg lang na bijwerken pakketten

Berichtdoor TSchevan » Di 06 Sep 2016, 21:16

Wilfried1954 schreef:Het antwoord van Nom001 is vermoedelijk niet slecht bedoeld hoor, maar eerder als ondersteuning van wat door te bijten. We geraken er wel door.

Ja, daar ga ik ook wel van uit.

dirkjanl schreef:Er waren wat issues als W10 en Linux op een schijf staan met dual boot. Misschien op zoeken?
Zelf heb ik gekozen voor 2 SSD stations, gewoon voor de zekerheid. 1 voor Windows 7 (de grote SSD) en 1 voor Linux (de kleine SSD).

Nou ja, die dualboot werkt op zich prima bij mij. Andere issues ben ik (nog) niet op het internet tegengekomen.
Ik heb de hele installatie nog een extra keer gedaan (nu dus een tri-boot (of een polyboot?)) om na te gaan op welk punt van de installatie, of bijwerken van de pakketten na installatie, het fout gaat met de Boot- en Afsluit routine. Omdat ik geen ruimte op de SSD beschikbaar had is die laatste installatie op de HDD geplaatst.
Gevolg, op de HDD geen vertraging bij Afsluiten; 15-20 seconden tegen ruim 80 bij de SSD-installatie. Het heeft kennelijk wel iets met de SSD schijf te maken.
Bij het Opstarten is maar weinig tijdwinst, allebei ca. 40 seconden, maar de reden waarom verschilt. De HDD is relatief traag, terwijl bij de SSD het hangt op een onderdeel.
systemd-analyze blame SSD-schijf (regels 1 en 3 wisselen nogal eens van positie bij elke opstart)
    34.909s lvm2-monitor.service
    8.868s NetworkManager-wait-online.service
    572ms mnt-621C1D191C1CE9B5.mount
    331ms apt-daily.service
    281ms gpu-manager.service
    271ms dev-sda5.device
    266ms ModemManager.service
    257ms accounts-daemon.service
    232ms loadcpufreq.service
    223ms virtualbox-guest-utils.service
    223ms grub-common.service
    205ms nmbd.service
    180ms samba-ad-dc.service
    165ms polkitd.service
    135ms smbd.service
    105ms ufw.service
    96ms systemd-logind.service
    95ms networking.service
    etc
systemd-analyze blame HDD-schijf
    6.914s lvm2-monitor.service
    5.754s ufw.service
    5.206s dev-sdb6.device
    4.009s accounts-daemon.service
    3.719s ModemManager.service
    3.170s NetworkManager.service
    2.958s apt-daily.service
    2.836s thermald.service
    2.341s gpu-manager.service
    2.214s networking.service
    2.190s loadcpufreq.service
    etc
Desktop: Intel I5-4570 CPU @ 3.20GHz x 4. Ram 8G. Videokaart NVIDIA GTX 650 Ti Boost.
Dualboot Windows10 en Linux Mint Sarah Cinnamon 64-bit (3.0.7), beide op SSD 128G.
---------------------
"I'll rant as well as thou!" - Hamlet

Terug naar “Installatie & Boot”

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers en 1 gast