Usb-wifi stick voor LM19

Allerhande Hardware vragen
oldbutMint
Senior
Senior
Berichten: 157
Lid geworden op: Vr 30 Sep 2016, 09:10

Usb-wifi stick voor LM19

Berichtdoor oldbutMint » Zo 09 Feb 2020, 15:15

Hallo,

De wifi module in mijn HP-laptop (LM19.1) lijkt overleden te zijn.
Weet iemand een aan te raden usb-wifi-stick, die met zekerheid goed werkt met LM (en andere linuxen)?

Dank voor suggesties.
oldbutmint
Gebruikersavatar
Pjotr
Guru
Guru
Berichten: 767
Lid geworden op: Zo 03 Jan 2016, 15:44

Re: Usb-wifi stick voor LM19

Berichtdoor Pjotr » Zo 09 Feb 2020, 15:47

Die weet ik wel voor je, maar laten we eerst eens kijken naar die interne WiFi-kaart. Post hier eens een volledig systeemoverzicht, op de volgende wijze:

Code: Selecteer alles

inxi -Fxz
En tevens de uitkomst van:

Code: Selecteer alles

rfkill list all

Code: Selecteer alles

iwconfig

Code: Selecteer alles

lsusb

Code: Selecteer alles

lspci
Tip: doe deze 10 dingen direct na installatie van Linux Mint 20 Ulyana
Houd je Linux Mint gezond: vermijd deze 10 fatale vergissingen
Twitter: Linuxtip
Alles is te kraken en niets is geheel veilig. Zorg dus voor zoveel mogelijk niets.
oldbutMint
Senior
Senior
Berichten: 157
Lid geworden op: Vr 30 Sep 2016, 09:10

Re: Usb-wifi stick voor LM19

Berichtdoor oldbutMint » Zo 09 Feb 2020, 20:11

Even vooraf: sinds ik de betreffende computer via wifi gebruik viel de wifi verbinding met de router op onregelmatige momenten weg, en was er weer na het rebooten van de computer. Ik zag geen samenhang met activiteiten van mij op de computer.
Misschien is dit een indicatie dat de wifi-module aan het doodgaan was?

De gevraagde outputs (opgenomen net voor deze post):

NB: bluetooth heb/had ik in het bios uitgezet omdat ik geen bluetooth apparaten heb.

user@computer:~$ sudo inxi -Fxz
[sudo] password for user:
System:
Host: hpcompaq Kernel: 4.15.0-76-generic i686 bits: 32 compiler: gcc
v: 7.4.0 Desktop: MATE 1.20.1 Distro: Linux Mint 19.1 Tessa
base: Ubuntu 18.04 bionic
Machine:
Type: Laptop System: Hewlett-Packard
product: HP Compaq 6710b (KE121ET#ABH) v: F.13 serial: <filter>
Mobo: Hewlett-Packard model: 30C0 v: KBC Version 71.2E serial: N/A
BIOS: Hewlett-Packard v: 68DDU Ver. F.13 date: 08/18/2008
Battery:
ID-1: C23B charge: 38.2 Wh condition: 39.6/39.6 Wh (100%)
model: Hewlett-Packard Primary status: Unknown
CPU:
Topology: Dual Core model: Intel Core2 Duo T8100 bits: 64 type: MCP
arch: Penryn rev: 6 L2 cache: 3072 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 8379
Speed: 798 MHz min/max: 800/2100 MHz Core speeds (MHz): 1: 798 2: 798
Graphics:
Device-1: Intel Mobile GM965/GL960 Integrated Graphics
vendor: Hewlett-Packard Compaq 6710b driver: i915 v: kernel
bus ID: 00:02.0
Display: server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa
resolution: 1280x800~60Hz
OpenGL: renderer: Mesa DRI Intel 965GM x86/MMX/SSE2 v: 2.1 Mesa 19.2.8
direct render: Yes
Audio:
Device-1: Intel 82801H HD Audio vendor: Hewlett-Packard Compaq 6710b
driver: snd_hda_intel v: kernel bus ID: 00:1b.0
Sound Server: ALSA v: k4.15.0-76-generic
Network:
Device-1: Intel PRO/Wireless 3945ABG [Golan] Network
vendor: Hewlett-Packard driver: iwl3945 v: in-tree:s port: 4100
bus ID: 10:00.0
IF: wlp16s0 state: down mac: <filter>
Device-2: Broadcom and subsidiaries NetLink BCM5787M Gigabit Ethernet PCI
Express
vendor: Hewlett-Packard driver: tg3 v: 3.137 port: 4100 bus ID: 18:00.0
IF: ens1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 232.89 GiB used: 207.90 GiB (89.3%)
ID-1: /dev/sda vendor: Hitachi model: HTS545025B9A300 size: 232.89 GiB
Partition:
ID-1: / size: 27.37 GiB used: 23.57 GiB (86.1%) fs: ext4 dev: /dev/sda1
ID-2: /home size: 63.67 GiB used: 57.78 GiB (90.8%) fs: ext4
dev: /dev/sda2
ID-3: swap-1 size: 3.81 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4
Sensors:
System Temperatures: cpu: 65.0 C mobo: 20.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 188 Uptime: 5m Memory: 3.87 GiB used: 1.24 GiB (32.1%)
Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20
inxi: 3.0.27
user@computer:~$

user@computer:~$ sudo rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
1: hp-wifi: Wireless LAN
Soft blocked: no
Hard blocked: yes
2: hp-bluetooth: Bluetooth
Soft blocked: yes
Hard blocked: yes
user@computer:~$

user@computer:~$ sudo iwconfig
wlp16s0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

ens1 no wireless extensions.

lo no wireless extensions.

user@computer:~$

user@computer:~$ sudo lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
user@computer:~$

user@computer:~$ sudo lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 0c)
00:1a.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HM (ICH8M) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] (rev 03)
02:04.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b6)
02:04.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 02)
10:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
18:00.0 Ethernet controller: Broadcom Inc. and subsidiaries NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
user@computer:~$
Gebruikersavatar
Pjotr
Guru
Guru
Berichten: 767
Lid geworden op: Zo 03 Jan 2016, 15:44

Re: Usb-wifi stick voor LM19

Berichtdoor Pjotr » Ma 10 Feb 2020, 12:56

Gebruik geen sudo bij rfkill. ;)

Ik zie "hard blocked" staan. Kijk eens of er een piepklein minischakelaartje is voor de WiFi, want ouwe flaptoppen hebben die vaak. Meestal op de voorkant-rand (toetsenbordgedeelte). Het lijkt erop dat je WiFi daarmee is uitgeschakeld.
Tip: doe deze 10 dingen direct na installatie van Linux Mint 20 Ulyana
Houd je Linux Mint gezond: vermijd deze 10 fatale vergissingen
Twitter: Linuxtip
Alles is te kraken en niets is geheel veilig. Zorg dus voor zoveel mogelijk niets.
oldbutMint
Senior
Senior
Berichten: 157
Lid geworden op: Vr 30 Sep 2016, 09:10

[OPGELOST] Re: Usb-wifi stick voor LM19

Berichtdoor oldbutMint » Ma 10 Feb 2020, 13:31

Schaam schaam...
Mijn flaptop heeft aan de voorrand een blauw ledje en boven de functietoetsen een blauw led-zendmastsymbooltje (wat ook een tiptoets is)
Ik had niet bemerkt dat beide blauwtjes uit waren.
Na het bedienen van de tiptoets werkt de wifi weer (lekker voordelig).
Ik moet bij het hanteren van de flaptop per ongeluk op de tiptoets gedrukt/deze aangeraakt hebben,

Dank voor je deskundig advies,

oldbutmint

Terug naar “Hardware en Drivers”

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers en 2 gasten