Swapneiging verlagen werkt niet

Vragen over Grub, de liveCD en de installer
Lucien
Held
Held
Berichten: 543
Lid geworden op: Di 12 Jun 2012, 01:46

Swapneiging verlagen werkt niet

Berichtdoor Lucien » Do 02 Apr 2020, 11:46

Na een fresh install van Mint werk ik altijd het lijstje af van de site 'Makkelijke Linux Tips' '10 dingen die je direct na installatie moet doen'. Een van de acties is het via de terminal verlagen van de swapneiging van 60 naar 10 (of naar 5 bij een ssd) en dat gaat altijd probleemloos. Deze keer krijg ik echter na het uitvoeren van de commando's de melding 'Errror De opgegeven locatie is niet aangekoppeld'. De swapneiging staat dan na afloop nog steeds op 60. Heb deze actie al meerdere keren uitgevoerd, maar deze melding heb ik nog nooit gehad en het zegt me ook niets.
Gebruikersavatar
Joan
LMNLVip
LMNLVip
Berichten: 2799
Lid geworden op: Do 16 Feb 2012, 00:49
Contact:

Re: Swapneiging verlagen werkt niet

Berichtdoor Joan » Do 02 Apr 2020, 14:52

Controleer met sudo blkid of het swap UUID overeen komt met de UUID van de swap in /etc/fstab

Als die gelijk zijn plaats hier eens de hele regel van de swap uit /etc/fstab.
Wil je een duidelijk antwoord? Stel dan een duidelijke vraag. , Kijk hoe dat moet bij Tips voor forumberichten.
Wil je een afbeelding plaatsen?. Kijk hoe dat kan bij Tip voor het plaatsen van afbeeldingen.
Lucien
Held
Held
Berichten: 543
Lid geworden op: Di 12 Jun 2012, 01:46

Re: Swapneiging verlagen werkt niet

Berichtdoor Lucien » Za 04 Apr 2020, 15:39

Ik zie geen overeenkomsten tussen wat op de terminal verschijnt en in /fstab. In de terminal staat vijf keer UUID onder elkaar met daar achter sda 1 t/m 5. Daar achter staat dan 82eda490-01 t/m 05.
Ik heb /fstab met een conversie overgezet naar txt zodat ik het hier onder kon plakken. Staat iet over errors. Zegt je dat iets?


# [etc/fstab: static file system information.

#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).

#
# (file systen> <nount point> <type> <options> <dunp> <pass>
# I was on ldev/sdas during installation
UUID=bfzeOe4o-23ab-40e0-9bce-b2a6d7262d22 / ext4 errors=remount-ro o
[swapfile none swap 5w 0
Gebruikersavatar
Joan
LMNLVip
LMNLVip
Berichten: 2799
Lid geworden op: Do 16 Feb 2012, 00:49
Contact:

Re: Swapneiging verlagen werkt niet

Berichtdoor Joan » Za 04 Apr 2020, 16:38

Alles lijkt normaal

5x een UUID betekent dat je 5 partities hebt. Swapfile staat daar niet bij want dat is geen partitie.

UUID=bfzeOe4o-23ab-40e0-9bce-b2a6d7262d22 / ext4 errors=remount-ro o
Het errors=remount-ro o (met nog een 1 er achter) betekent dat bij eventuele fouten deze (systeem) partitie weer wordt aangekoppeld.
De 1 die in jouw tekst ontbreekt betekend dat deze partitie als eerste wordt gecontroleerd.

[swapfile none swap 5w 0
Dit is waarschijnlijk /swapfile none swap sw 0 0

Het moet dus zijn

Code: Selecteer alles

UUID=bfzeOe4o-23ab-40e0-9bce-b2a6d7262d22 / ext4 errors=remount-ro 0 1
/swapfile none swap sw 0 0
Als dat niet zo is kopieer en plak deze twee regels dan over de regels van jouw fstab.
* Let op - dat het UUID nummer wel goed is. Controleer dat nogmaals met sudo blkid.

Overigens hoef je de tekst uit de terminal niet eerst te converteren, je kunt het direct kopiëren en plakken want het is gewoon platte tekst.
Wil je een duidelijk antwoord? Stel dan een duidelijke vraag. , Kijk hoe dat moet bij Tips voor forumberichten.
Wil je een afbeelding plaatsen?. Kijk hoe dat kan bij Tip voor het plaatsen van afbeeldingen.
Lucien
Held
Held
Berichten: 543
Lid geworden op: Di 12 Jun 2012, 01:46

Re: Swapneiging verlagen werkt niet

Berichtdoor Lucien » Za 04 Apr 2020, 22:34

Ik kon niets terugvinden, tot ik ontdekte dat ik de info van de verkeerde laptop had geplukt. Heb er meerdere. Sorry Sorry!.

Deze laat op de terminal maar 1 UUID zien met sda1. Dus blijkbaar maar 1 partitie.
Onderstaand de fstab.

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda1 during installation
UUID=3d65ee9f-b023-425c-8480-9b8dbfac43fe / ext4 errors=remount-ro 0 1
/swapfile none swap sw 0 0
Gebruikersavatar
Joan
LMNLVip
LMNLVip
Berichten: 2799
Lid geworden op: Do 16 Feb 2012, 00:49
Contact:

Re: Swapneiging verlagen werkt niet

Berichtdoor Joan » Za 04 Apr 2020, 22:53

Dan terug naar je vraag.
Welk commando heb je gebruikt om de swap te verlagen?
Wil je een duidelijk antwoord? Stel dan een duidelijke vraag. , Kijk hoe dat moet bij Tips voor forumberichten.
Wil je een afbeelding plaatsen?. Kijk hoe dat kan bij Tip voor het plaatsen van afbeeldingen.
Lucien
Held
Held
Berichten: 543
Lid geworden op: Di 12 Jun 2012, 01:46

Re: Swapneiging verlagen werkt niet

Berichtdoor Lucien » Zo 05 Apr 2020, 13:12

xed admin:///etc/sysctl.conf
Dan krijg je een tekstblokje waar je dan een via kopiëren en plakken een tekstregel aan moet toevoegen. dat sla ik dan op, en vervolgens laptop herstarten.
Ik volg keurig dat hele lijstje van Linux Mint Tips (10 dingen die je na installatie direct moet doen) met kopiëren en plakken en dat heb ik al tientallen keren gedaan op mijn eigen desktop en laptops en op die van anderen. Bv na installatie en na het vervangen van hdd's naar ssd's de swap op 5 zetten. Nooit dit probleem gehad.
Lucien
Held
Held
Berichten: 543
Lid geworden op: Di 12 Jun 2012, 01:46

Re: Swapneiging verlagen werkt niet

Berichtdoor Lucien » Zo 05 Apr 2020, 13:33

Gisteravond heb ik nogmaals dat hele lijstje afgewerkt en de swap op 5 gezet, inclusief de laptop opnieuw opstarten. En na opnieuw opstarten gaf het controle commando in de terminal nog steeds swap 60. Vanmiddag de laptop weer opgestart en nu staat hij wel op swap 5!!!!! Maar in fstab staat nog steeds die error. Het enige dat me bij het starten opviel is dat het erg lang duurde.
Gebruikersavatar
Joan
LMNLVip
LMNLVip
Berichten: 2799
Lid geworden op: Do 16 Feb 2012, 00:49
Contact:

Re: Swapneiging verlagen werkt niet

Berichtdoor Joan » Zo 05 Apr 2020, 15:34

errors=remount-ro hoort in fstab bij de systeem partitie, anders zou het systeem vastlopen als er ergens een fout optreedt.

Erg lang, is subjectief. Omdat het je de eerste keren ook niet is gelukt vermoed ik dat er ergens nog een fout is ingeslopen en mogelijk de start ophoudt, waardoor errors=remount-ro zijn werk doet en toch probeert te starten.
Wil je een duidelijk antwoord? Stel dan een duidelijke vraag. , Kijk hoe dat moet bij Tips voor forumberichten.
Wil je een afbeelding plaatsen?. Kijk hoe dat kan bij Tip voor het plaatsen van afbeeldingen.
Lucien
Held
Held
Berichten: 543
Lid geworden op: Di 12 Jun 2012, 01:46

Re: Swapneiging verlagen werkt niet

Berichtdoor Lucien » Zo 05 Apr 2020, 20:44

Ik kijk het dan maar even aan. Ik ben gewend aan een X250 en deze R61 is veel ouder dus bij alles wat trager. Als er verder rare dingen gebeuren installeer ik Mint maar opnieuw. Jammer dat er geen herstel-optie is. In ieder geval weer dank voor de support.
Gebruikersavatar
Joan
LMNLVip
LMNLVip
Berichten: 2799
Lid geworden op: Do 16 Feb 2012, 00:49
Contact:

Re: Swapneiging verlagen werkt niet

Berichtdoor Joan » Ma 06 Apr 2020, 00:00

Je had van te voren een Timeshift kunnen maken.
Wil je een duidelijk antwoord? Stel dan een duidelijke vraag. , Kijk hoe dat moet bij Tips voor forumberichten.
Wil je een afbeelding plaatsen?. Kijk hoe dat kan bij Tip voor het plaatsen van afbeeldingen.

Terug naar “Installatie & Boot”

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers en 2 gasten