Videokaart wordt niet herkent

Vragen over Grub, de liveCD en de installer
DannyJ
Nieuweling
Nieuweling
Berichten: 6
Lid geworden op: Ma 26 Jul 2021, 16:54

Videokaart wordt niet herkent

Berichtdoor DannyJ » Ma 26 Jul 2021, 17:43

Pas mijn systeem geüpgrade van LM 18.1 naar LM 20.1
Bij het opstarten kreeg ik alleen het bureaublad achtergrond te zien.
Na gebruik van Nomodeset had ik normaal beeld.
Echter krijg ik de melding van het stuurprogramma na te kijken want videoversnelling is uitgeschakeld.
Als ik bij stuurprogrammabeheer ga zien staat daar dat er geen veranderingen nodig zijn. (er zijn geen keuzes te zien)
Ook kan ik geen 2 beeldschermen gebruiken.
Systeemgegevens:

Code: Selecteer alles

System: Kernel: 5.4.0-80-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.8.6
Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal
Machine: Type: Desktop System: Hewlett-Packard product: p6-2427eb v: N/A serial: <filter>
Mobo: Foxconn model: 2ADA v: 1.00 serial: <filter> UEFI: AMI v: 8.15 date: 02/05/2013
CPU: Topology: Quad Core model: Intel Core i7-3770 bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 L2 cache: 8192 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 54277
Speed: 2640 MHz min/max: 1600/3900 MHz Core speeds (MHz): 1: 3692 2: 3683 3: 3685 4: 3675 5: 3694 6: 3692 7: 3710
8: 3692
Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Oland [Radeon HD 8570 / R7 240/340 / Radeon 520 OEM] vendor: Pegatron
driver: N/A bus ID: 01:00.0
Display: x11 server: X.Org 1.20.9 driver: ati,fbdev unloaded: modesetting,radeon,vesa resolution: 1920x1080~77Hz
OpenGL: renderer: llvmpipe (LLVM 11.0.0 256 bits) v: 4.5 Mesa 20.2.6 direct render: Yes
Audio: Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel
v: kernel bus ID: 00:1b.0
Device-2: AMD Oland/Hainan/Cape Verde/Pitcairn HDMI Audio [Radeon HD 7000 Series] vendor: Pegatron
driver: snd_hda_intel v: kernel bus ID: 01:00.1
Sound Server: ALSA v: k5.4.0-80-generic
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel
port: d000 bus ID: 03:00.0
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives: Local Storage: total: 1.35 TiB used: 19.83 GiB (1.4%)
ID-1: /dev/sda vendor: Intenso model: SSD Sata III size: 447.13 GiB
ID-2: /dev/sdb vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB
Partition: ID-1: / size: 148.68 GiB used: 19.79 GiB (13.3%) fs: ext4 dev: /dev/sda6
ID-2: swap-1 size: 15.96 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda7
Sensors: System Temperatures: cpu: 57.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info: Processes: 236 Uptime: 6h 38m Memory: 15.59 GiB used: 2.37 GiB (15.2%) Init: systemd runlevel: 5 Compilers:
gcc: 9.3.0 Shell: bash v: 5.0.17 inxi: 3.0.38
Computer is van 2013
Er zit een Nvidia geforce 630 2gb kaart in (zonder GT)
Deze kaart vindt hij dus niet (bij LM 18.1 dus wel)

Is er een manier om deze te herkennen?
Gebruikersavatar
Jamint
Held
Held
Berichten: 310
Lid geworden op: Zo 21 Jan 2018, 22:10
Locatie: Noord-Brabant NL

Re: Videokaart wordt niet herkent

Berichtdoor Jamint » Ma 26 Jul 2021, 18:52

Heb je in het begin van het Linux 20.1 installatieproces aangevinkt: Installeer programmatuur voor videokaarten van derden alsmede.... (Exact weet ik hier verder niet meer de tekst.)
Dat is een installatie optie dus staat niet standaard aangevinkt/aangekruist.
Als je dat niet hebt gedaan is dit misschien de oorzaak van je probleem.
If it ain't broken, don't fix it.
DannyJ
Nieuweling
Nieuweling
Berichten: 6
Lid geworden op: Ma 26 Jul 2021, 16:54

Re: Videokaart wordt niet herkent

Berichtdoor DannyJ » Ma 26 Jul 2021, 20:10

Die vraag heb ik niet gekregen denk ik.
Wel voor multimediaondersteuning.
Gebruikersavatar
Jamint
Held
Held
Berichten: 310
Lid geworden op: Zo 21 Jan 2018, 22:10
Locatie: Noord-Brabant NL

Re: Videokaart wordt niet herkent

Berichtdoor Jamint » Ma 26 Jul 2021, 20:22

TOEGEVOEGD:

Ik moest er even naar zoeken omdat ik geen gebruik maak van een separate graphics card maar kijk zeker ook op onderstaande website:

https://makkelijkelinuxtips.blogspot.co ... a.html#ID1


Ps. Als dit de oplossing voor je biedt meld je dit dan even terug? ;)
Dat is altijd fijn voor anderen om te weten die misschien tegen hetzelfde aanlopen, en niet in het minst voor degene welke die website beheert en onderhoudt.
If it ain't broken, don't fix it.
DannyJ
Nieuweling
Nieuweling
Berichten: 6
Lid geworden op: Ma 26 Jul 2021, 16:54

Re: Videokaart wordt niet herkent

Berichtdoor DannyJ » Ma 26 Jul 2021, 21:56

De videokaart is toch Nvidia Geforce GT 630 2gb (blijkbaar er over gekeken)

Installatie via PPA heb ik gedaan maar levert geen resultaat op

Deze 3 meldingen staan in het logboek
GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)
[drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.
[drm:radeon_init [radeon]] *ERROR* No UMS support in radeon module!
Gebruikersavatar
emvedeesje
Held
Held
Berichten: 494
Lid geworden op: Zo 17 Jun 2018, 11:03
Locatie: Aalter-Ovl-Belgie

Re: Videokaart wordt niet herkent

Berichtdoor emvedeesje » Di 27 Jul 2021, 09:11

Upgrade van 18 naar 20 ?
OF
Verse installatie van 20 ?

Dat maakt een groot verschil.

Het eerste zou ik nooit doen, het tweede is de enige goede oplossing.

groeten van Michael
Mint cinnamon fan
Mint cinnamon -20.2 (vorige linux: Mint-19 Mint-18 Mint-17 Ubuntu-16 Ubuntu-14 Ubuntu-12)
DannyJ
Nieuweling
Nieuweling
Berichten: 6
Lid geworden op: Ma 26 Jul 2021, 16:54

Re: Videokaart wordt niet herkent

Berichtdoor DannyJ » Di 27 Jul 2021, 19:27

Schone installatie
Gebruikersavatar
dirkjanl
Held
Held
Berichten: 738
Lid geworden op: Do 21 Mar 2013, 13:40
Locatie: Borger
Contact:

Re: Videokaart wordt niet herkent

Berichtdoor dirkjanl » Di 27 Jul 2021, 21:49

Als ik het me goed herinner kan je onder 'Stuurprogrammabeheer' ook de open source driver selecteren voor de Nvidia kaart. Dat zou ik proberen. Let wel, ik weet niet wat deinvloed hiervan precies is, dus misschien even checken wat anderen hierover te melden hebben.
Linux Mint 19.3 en LM 20 Cinnamon op productiePC's. Op testbak LM 20.2 Cin. APLinux op MuziekPC Gouden tips: viewtopic.php?f=1&t=3264
DannyJ
Nieuweling
Nieuweling
Berichten: 6
Lid geworden op: Ma 26 Jul 2021, 16:54

Re: Videokaart wordt niet herkent

Berichtdoor DannyJ » Wo 28 Jul 2021, 10:41

In het stuurprogrammabeheer wordt er na het zoeken naar drivers gemeld dat er geen andere driver nodig is.
Er is ook geen mogelijkheid tot een keuze.
DannyJ
Nieuweling
Nieuweling
Berichten: 6
Lid geworden op: Ma 26 Jul 2021, 16:54

Re: Videokaart wordt niet herkent

Berichtdoor DannyJ » Za 31 Jul 2021, 12:08

Lm 19.2 geprobeerd in live sessie.
Ook hier kreeg ik eerst alleen het achtergrondscherm. Door het gebruik van nomodeset werkt het wel (echter 1 scherm)
Na nog wat proberen ook het tweede scherm aangezet. Dat werkte, op scherm 1 alleen de achtergrond en op scherm 2 het bureaublad.
Scherm 2 was dus mijn hoofdscherm (dat ik dus niet zag omdat het niet aangesloten was)

Bij LM 20.2 de nomodeset terug weggedaan en ook hier werkte het met 2 schermen.
Mijn primair scherm bepaald en ok.

Mijn grafische kaart ziet hij nog niet denk ik maar stuurprogramma geeft geen foutmelding
In het logboek staat nog volgende:
radeon 0000:01:00.0: failed VCE resume (-110).

Code: Selecteer alles

System:
Kernel: 5.4.0-80-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
Desktop: Cinnamon 4.8.6 Distro: Linux Mint 20.1 Ulyssa
base: Ubuntu 20.04 focal
Machine:
Type: Desktop System: Hewlett-Packard product: p6-2427eb v: N/A
serial: <filter>
Mobo: Foxconn model: 2ADA v: 1.00 serial: <filter> UEFI: AMI v: 8.15
date: 02/05/2013
Memory:
RAM: total: 15.59 GiB used: 2.07 GiB (13.3%)
RAM Report:
permissions: Unable to run dmidecode. Root privileges required.
CPU:
Topology: Quad Core model: Intel Core i7-3770 bits: 64 type: MT MCP
arch: Ivy Bridge rev: 9 L2 cache: 8192 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 54278
Speed: 1597 MHz min/max: 1600/3900 MHz Core speeds (MHz): 1: 1596 2: 1597
3: 1597 4: 1597 5: 1597 6: 1597 7: 1596 8: 1596
Graphics:
Device-1: AMD Oland [Radeon HD 8570 / R7 240/340 / Radeon 520 OEM]
vendor: Pegatron driver: radeon v: kernel bus ID: 01:00.0
Display: x11 server: X.Org 1.20.9 driver: ati,radeon
unloaded: fbdev,modesetting,vesa resolution: 1600x900~60Hz, 1920x1080~60Hz
OpenGL: renderer: AMD OLAND (DRM 2.50.0 5.4.0-80-generic LLVM 11.0.0)
v: 4.5 Mesa 20.2.6 direct render: Yes
Audio:
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0
Device-2: AMD Oland/Hainan/Cape Verde/Pitcairn HDMI Audio [Radeon HD 7000
Series]
vendor: Pegatron driver: snd_hda_intel v: kernel bus ID: 01:00.1
Sound Server: ALSA v: k5.4.0-80-generic
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel port: d000 bus ID: 03:00.0
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
Local Storage: total: 1.35 TiB used: 24.75 GiB (1.8%)
ID-1: /dev/sda vendor: Intenso model: SSD Sata III size: 447.13 GiB
ID-2: /dev/sdb vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB
Partition:
ID-1: / size: 148.68 GiB used: 24.71 GiB (16.6%) fs: ext4 dev: /dev/sda6
ID-2: /boot/efi size: 343.9 MiB used: 44.9 MiB (13.0%) fs: vfat
dev: /dev/sda2
ID-3: /run/timeshift/backup raw size: 152.07 GiB
size: <superuser/root required> used: <superuser/root required> fs: ext4
dev: /dev/sda6
ID-4: swap-1 size: 15.96 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda7
Sensors:
System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: radeon temp: 50 C
Fan Speeds (RPM): N/A
Repos:
No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/eid.list
1: deb http://files.eid.belgium.be/debian ulyana main
2: deb http://files2.eid.belgium.be/debian ulyana main
Active apt repos in: /etc/apt/sources.list.d/google-chrome.list
1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
Active apt repos in: /etc/apt/sources.list.d/graphics-drivers-ppa-focal.list
1: deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu focal main
Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
1: deb http://packages.linuxmint.com ulyssa main upstream import backport #id:linuxmint_main
2: deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
3: deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
4: deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
6: deb http://archive.canonical.com/ubuntu/ focal partner
Active apt repos in: /etc/apt/sources.list.d/skype-stable.list
1: deb [arch=amd64] https://repo.skype.com/deb stable main
Info:
Processes: 249 Uptime: 40m Init: systemd runlevel: 5 Compilers: gcc: 9.3.0
Shell: bash v: 5.0.17 inxi: 3.0.38
Alvast voor het meedenken

Terug naar “Installatie & Boot”

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers en 3 gasten