Don’t break DEBIAN , lees LMDE …

tytsjerksteradiel
Held
Held
Berichten: 343
Lid geworden op: Ma 16 Dec 2019, 01:16

Don’t break DEBIAN , lees LMDE …

Berichtdoor tytsjerksteradiel » Do 01 Apr 2021, 01:35

wat voor Debian geldt , geldt in grote lijnen voor LMDE

https://wiki.debian.org/DontBreakDebian
vertaald gebruikmakend van https://www.vertalen.nu/zinnen/

Advies voor nieuwe gebruikers om hun Debian-systeem niet kapot te maken
Debian is een robuust en betrouwbaar systeem, maar gebruikers met root-toegang kunnen elke gewenste wijziging aanbrengen. Als zodanig is het voor nieuwe gebruikers heel gemakkelijk om hun systemen te breken door de dingen niet op de Debian-manier te doen. Op deze pagina staan ​​veelgemaakte fouten van nieuwe gebruikers. Sommige van de dingen die hier worden vermeld, kunnen veilig worden gedaan, maar alleen als u voldoende ervaring heeft om te weten hoe u uw systeem kunt herstellen als er iets misgaat.
Het algemene thema van het advies hier is dat de gevolgen niet altijd onmiddellijk zijn en toekomstige upgrades onmogelijk kunnen maken zonder een volledige herinstallatie. Als upgraden zonder een volledige herinstallatie belangrijk voor je is, pas dan op dat je de onderstaande fouten niet maakt.
Een van de belangrijkste voordelen van Debian is de centrale opslagplaats met vele duizenden softwarepakketten. Als u naar Debian komt vanuit een ander besturingssysteem, bent u misschien gewend om software te installeren die u op willekeurige websites vindt. Op Debian is het installeren van software van willekeurige websites een slechte gewoonte. Het is altijd beter om indien mogelijk software uit de officiële Debian-repositories te gebruiken. Het is bekend dat de pakketten in de Debian-repositories goed werken en correct worden geïnstalleerd. Alleen software uit de Debian-repositories gebruiken is ook veel veiliger dan installeren vanaf willekeurige websites die malware en andere veiligheidsrisico's kunnen bundelen.

Maak geen FrankenDebian
Debian Stable mag niet onzorgvuldig gecombineerd worden met andere releases. Als u software probeert te installeren die niet beschikbaar is in de huidige release van Debian Stable, is het geen goed idee om repositories voor andere releases van Debian toe te voegen.
Allereerst is het standaardgedrag van apt-get upgrade het upgraden van elk geïnstalleerd pakket naar de hoogst beschikbare versie. Als u bijvoorbeeld het bullseye-archief configureert op een buster-systeem, zal APT proberen bijna alle pakketten naar bullseye te upgraden.
Dit kan worden beperkt door apt pinning te configureren om prioriteit te geven aan pakketten van buster.
Maar zelfs het installeren van enkele pakketten uit een "toekomstige" uitgave kan riskant zijn. De problemen treden misschien niet meteen op, maar de volgende keer dat u updates installeert.
De reden waarom dingen kapot kunnen gaan, is omdat de software die voor één Debian-uitgave is verpakt, is gebouwd om compatibel te zijn met de rest van de software voor die uitgave. Het installeren van pakketten van bullseye op een buster-systeem zou bijvoorbeeld ook nieuwere versies van kernbibliotheken kunnen installeren, waaronder libc6. Dit resulteert in een systeem dat niet test of stabiel is, maar een gebroken mix van beide.
Repositories die een FrankenDebian kunnen creëren indien gebruikt met Debian Stable:
Debian testrelease (momenteel bullseye)
Debian unstable release (ook bekend als sid)
Ubuntu, Mint of andere afgeleide repositories zijn niet compatibel met Debian!
Ubuntu PPA's en andere repositories gemaakt om afzonderlijke applicaties te distribueren
Sommige opslagplaatsen van derden lijken misschien veilig om te gebruiken, aangezien ze alleen pakketten bevatten die geen equivalent hebben in Debian. Er zijn echter geen garanties dat een repository in de toekomst niet meer pakketten zal toevoegen, wat tot breuk leidt.
Ten slotte zijn pakketten in officiële Debian-uitgaven uitgebreid getest, vaak maandenlang, en alleen geschikte pakketten zijn toegestaan ​​in een uitgave. Aan de andere kant kunnen pakketten van externe bronnen bestanden van andere pakketten wijzigen, het systeem op onverwachte manieren configureren, kwetsbaarheden introduceren en licentieproblemen veroorzaken.
Als pakketten van niet-officiële bronnen eenmaal in een systeem zijn geïntroduceerd, kan het moeilijk worden om de oorzaak van het breken te achterhalen, vooral als dit na maanden gebeurt.

Gebruik geen installatiescripts van de GPU-fabrikant
Debian bevat gratis en open-source stuurprogramma's die de meeste videokaarten ondersteunen. De gratis stuurprogramma's bieden de beste integratie met de rest van het Debian-systeem en werken redelijk goed voor de meeste gebruikers.

Als u absoluut de gepatenteerde closed-source stuurprogramma's nodig heeft, download deze dan niet rechtstreeks van de website van de fabrikant! Het op deze manier installeren van stuurprogramma's werkt alleen voor de huidige kernel, en na de volgende kernelupdate zullen je videostuurprogramma's niet werken totdat ze handmatig opnieuw worden geïnstalleerd.
Gelukkig is er een Debian-manier om stuurprogramma's voor videokaarten te installeren met behulp van pakketten in de repository. Door de stuurprogramma's op de Debian-manier te installeren, zorgt u ervoor dat de stuurprogramma's blijven werken na kernelupdates.

Lijd niet aan het Shiny New Stuff Syndrome.
De reden dat Debian Stable zo betrouwbaar is, is dat software uitgebreid wordt getest en fouten verholpen voordat deze wordt toegevoegd. Dit betekent dat de meest recente softwareversie vaak niet beschikbaar is in de stabiele repositories. Maar het betekent niet dat de software te oud is om nog bruikbaar te zijn!
Voordat u probeert de nieuwste versie van sommige software te installeren vanaf een andere plaats dan de Debian Stable-repositories, zijn hier enkele dingen die u in gedachten moet houden:
Debian backports-beveiligingsreparaties en betrouwbaarheidsreparaties. Software beoordelen door het versienummer van het Debian-pakket te vergelijken met het upstream-versienummer houdt hier geen rekening mee.
Het installeren van software op andere plaatsen dan officiële Debian-repositories valt niet onder het beveiligingsteam van Debian.
Let op: bugs worden gevonden in bestaande software, maar alleen nieuwe releases van software kunnen nieuwe bugs en kwetsbaarheden introduceren.
Als een uitgave Debian binnenkomt en bugfixes ontvangt, zal het aantal onbekende kwetsbaarheden en bugs constant afnemen tijdens de levensduur van het pakket.

'make install' kan conflicteren met pakketten.
Het is vrij eenvoudig om software te compileren met broncode-tarballs die zijn gedownload van de website van de software, maar het is niet altijd zo gemakkelijk om het later te verwijderen. Vaak bevatten de instructies die bij de broncode worden geleverd instructies om commando's zoals ./configure && make && make install te gebruiken.
Wanneer u op deze manier software installeert, kunt u deze niet verwijderen met apt-get of Synaptic. Het APT-verpakkingssysteem kan alleen software verwijderen die is geïnstalleerd door het APT-verpakkingssysteem. Erger nog, software die op deze manier wordt geïnstalleerd, kan soms conflicteren met de software die voor Debian is verpakt.
Software die op deze manier is geïnstalleerd, profiteert ook niet van beveiligingsupdates zoals Debian-pakketten. Als u uw systeem up-to-date wilt houden zonder handmatig te hoeven compileren en opnieuw te installeren voor elke update, blijf dan bij de Debian-pakketten.
Het make install-script kan ongeldige aannames doen over waar het gecompileerde binaire bestand en de bijbehorende bestanden in het bestandssysteem zouden moeten bestaan ​​en onder welke set rechten / eigendom het zou moeten draaien. Software die op deze manier wordt geïnstalleerd, kan ook belangrijke software vervangen die van vitaal belang is voor systeem- en pakketonderhoud, waardoor het moeilijk wordt om uw systeem te repareren met standaard Debian-tools.

Volg slecht advies niet blindelings op
Helaas zijn er veel slechte adviezen op internet. Tutorials op blogs, forums en andere sites bevatten vaak instructies die uw systeem op subtiele manieren zullen breken. Volg niet simpelweg het eerste advies dat u vindt, of de tutorial die het gemakkelijkst lijkt. Besteed wat tijd aan het lezen van de documentatie en vergelijk het verschil tussen tutorials.
Het is beter om eerst de tijd te nemen om de juiste manier te vinden om iets te doen, dan om later nog meer tijd te besteden aan het repareren van een kapot systeem. Je zou je baby niet laten voeden door een willekeurige vreemde; voer geen commando's uit zonder eerst te begrijpen wat ze doen.
Blog- en forumberichten vervallen niet. Instructies die een paar jaar geleden misschien veilig waren, zijn misschien niet meer veilig om op te volgen. Blijf bij twijfel onderzoek doen en lees de documentatie van uw versie.

Software niet blindelings verwijderen
Als u een pakket verwijdert, moet de pakketbeheerder soms ook andere pakketten verwijderen. Dit komt doordat de aanvullende pakketten afhankelijk zijn van het pakket dat u probeert te verwijderen.
Als dit gebeurt, zal de pakketbeheerder u een lijst laten zien van alles wat zal worden verwijderd en om uw bevestiging vragen. Lees deze lijst goed door! Als u niet weet waarvoor sommige van de te verwijderen pakketten zijn, lees dan de beschrijvingen voor elk pakket. Doe bij twijfel meer onderzoek

Terug naar “Linux Mint Debian ( LMDE )”

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers en 2 gasten