gajim instaleren lukt niet.

Vragen over software en applicaties
linuxcar1
Junior
Junior
Berichten: 34
Lid geworden op: Za 07 Okt 2017, 15:04

gajim instaleren lukt niet.

Berichtdoor linuxcar1 » Do 26 Apr 2018, 14:53

via software beheer krijg ik de volgende melding:
"This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time."
" The following packages have unmet dependencies:

gajim: Depends: python3:any (>= 3.3.2-2~) but it is a virtual package
Depends: gir1.2-gtk-3.0 (>= 3.22) but 3.18.9-1ubuntu3.3 is to be installed"


als ik in terminal: "sudo apt-get install gajim" tik krijg ik:
"Unable to correct problems, you have held broken packages"

hoe los ik dit op?
(graag in jip en janneke taal en stappen plan)
Gebruikersavatar
Joan
LMNLVip
LMNLVip
Berichten: 2037
Lid geworden op: Do 16 Feb 2012, 00:49
Contact:

Re: gajim instaleren lukt niet.

Berichtdoor Joan » Do 26 Apr 2018, 15:06

Ga naar Bijwerkbeheer (Updatebeheer) , kies Pakketbronnen en ga naar Onderhoud.
Daar kun je het probleem waarschijnlijk wel herstellen.
Mint 19 Cinnamon 64bit , kernel 4.15 + gezamenlijke home voor LM 17.x - 18.x - 19
linuxcar1
Junior
Junior
Berichten: 34
Lid geworden op: Za 07 Okt 2017, 15:04

Re: gajim instaleren lukt niet.

Berichtdoor linuxcar1 » Do 26 Apr 2018, 15:31

Joan schreef:Ga naar Bijwerkbeheer (Updatebeheer) , kies Pakketbronnen en ga naar Onderhoud.
Daar kun je het probleem waarschijnlijk wel herstellen.


en dan? remove foreign packages?
Dit heb ik gedaan maar probleem blijft bestaan. (nadat ik nog ff sudo apt-get update hebt gedaan)
Gebruikersavatar
Joan
LMNLVip
LMNLVip
Berichten: 2037
Lid geworden op: Do 16 Feb 2012, 00:49
Contact:

Re: gajim instaleren lukt niet.

Berichtdoor Joan » Do 26 Apr 2018, 15:45

Soms is het nodig om de pc te herstarten.
Kijk ook eens met Synaptic bij Bewerken of je met "Defecte pakketten repareren" iets bereikt.
Mint 19 Cinnamon 64bit , kernel 4.15 + gezamenlijke home voor LM 17.x - 18.x - 19
linuxcar1
Junior
Junior
Berichten: 34
Lid geworden op: Za 07 Okt 2017, 15:04

Re: gajim instaleren lukt niet.

Berichtdoor linuxcar1 » Do 26 Apr 2018, 16:57

Joan schreef:Soms is het nodig om de pc te herstarten.
Kijk ook eens met Synaptic bij Bewerken of je met "Defecte pakketten repareren" iets bereikt.


ok, het is me gelukt om gajim te instaleren via softwarebeheer.
om OMEMO te instaleren moet ik alleen versie 0.16.6 of hoger hebben.
En dit is versie 0.16.5.
enig idee hoe ik dit upgrade?

Joan schreef:Soms is het nodig om de pc te herstarten.
Kijk ook eens met Synaptic bij Bewerken of je met "Defecte pakketten repareren" iets bereikt.

Als ik via "edit" op "fix broken packages" klik gebeurt er helemaal niks.



edit: heb ondertussen gajim weer verwijderd via software beheer en toen geprobeerd via terminal te installeren: sudo apt install gajim
in de hoop ik dan de nieuwste versie krijg.
Maar toen kreeg ik de melding:
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gajim : Depends: gir1.2-gtk-3.0 (>= 3.22) but 3.18.9-1ubuntu3.3 is to be installed
E: Unable to correct problems, you have held broken packages.


Nog steeds dus broken packages....
Gebruikersavatar
Leon
Held
Held
Berichten: 362
Lid geworden op: Vr 21 Nov 2014, 09:12

Re: gajim instaleren lukt niet.

Berichtdoor Leon » Do 26 Apr 2018, 17:25

Zelf downloaden uit de Ubuntu 17.10 repos
https://packages.ubuntu.com/search?keyw ... chon=names
In Ubuntu 18.04 en straks dus ook Mint 19 zit 1.01
LMDE 2 MATE x64
Gebruikersavatar
Joan
LMNLVip
LMNLVip
Berichten: 2037
Lid geworden op: Do 16 Feb 2012, 00:49
Contact:

Re: gajim instaleren lukt niet.

Berichtdoor Joan » Do 26 Apr 2018, 17:49

Mint 19 Cinnamon 64bit , kernel 4.15 + gezamenlijke home voor LM 17.x - 18.x - 19
Gebruikersavatar
Leon
Held
Held
Berichten: 362
Lid geworden op: Vr 21 Nov 2014, 09:12

Re: gajim instaleren lukt niet.

Berichtdoor Leon » Do 26 Apr 2018, 18:35

OMEMO is ontwikkeld voor mobiele devices en werkt uiteraard ook op gewone computers.
Wordt momenteel alleen (voor zover ik weet) gebruikt bij het XMPP protocol
https://en.wikipedia.org/wiki/OMEMO
LMDE 2 MATE x64
linuxcar1
Junior
Junior
Berichten: 34
Lid geworden op: Za 07 Okt 2017, 15:04

Re: gajim instaleren lukt niet.

Berichtdoor linuxcar1 » Do 26 Apr 2018, 20:37

Leon schreef:Zelf downloaden uit de Ubuntu 17.10 repos
https://packages.ubuntu.com/search?keyw ... chon=names
In Ubuntu 18.04 en straks dus ook Mint 19 zit 1.01


hartstikke bedankt voor de link.
ik begrijp alleen geen ene snars van wat er allemaal staat :$ (noob)
u wel?

kunt u misschien uitleggen wat ik precies moet doen?
(gegevens: intel, linux mint 18.3, 64 bit)
Gebruikersavatar
Leon
Held
Held
Berichten: 362
Lid geworden op: Vr 21 Nov 2014, 09:12

Re: gajim instaleren lukt niet.

Berichtdoor Leon » Do 26 Apr 2018, 22:43

Bij package gajim klikken op "artful"
Bij download gajim klikken op "all"
Dan op 1 van de servers klikken, bv de.archive.ubuntu
Je kan nu het pakket gajim_0.16.8-3_all.deb downloaden
LMDE 2 MATE x64
linuxcar1
Junior
Junior
Berichten: 34
Lid geworden op: Za 07 Okt 2017, 15:04

Re: gajim instaleren lukt niet.

Berichtdoor linuxcar1 » Do 26 Apr 2018, 23:15

Leon schreef:Bij package gajim klikken op "artful"
Bij download gajim klikken op "all"
Dan op 1 van de servers klikken, bv de.archive.ubuntu
Je kan nu het pakket gajim_0.16.8-3_all.deb downloaden


super, ik heb het helemaal aan het werk. Thanks!

Terug naar “Software en applicaties”

Wie is er online

Gebruikers op dit forum: loti en 4 gasten