Wine laat me in de steek

Vragen over software en applicaties
rednasje
Nieuweling
Nieuweling
Berichten: 4
Lid geworden op: Di 05 Nov 2019, 20:50

Wine laat me in de steek

Berichtdoor rednasje » Zo 17 Nov 2019, 14:54

Ola mensen.

Voordat ik begin wil ik graag even melden dat ik geen Linux wizzard ben, dus "please be gentle" ;)
Mijn probleem :
ik heb een cd waar een oa een reparatiehandleiding op staat van mijn motorfiets.
Uiteraard gemaakt voor windows, maar ik ga er vanuit dat ik e.e.a ook op Linux draaiend moet krijgen.
Voor het gemak heb ik de cd geript, zo heb ik tevens een backup van de cd en die heb ik gemount met Furious Mount op mijn laptop
Wat ik heb gedaan: Wine geinstallerd, (op Linux MInt 19.2 Mate), en het .exe bestand geopend met wine.
Dat lijkt te werken, het welkomstscherm opent zich, vervolgens kom ik het scherm waar ik het type motor moet selecteren, dat werkt ook prima.
Het volgende menu opent zich waar ik door de hoofdstukken kan bladeren met technische info en handleidingen etc.
Als ik vervolgens het hoofdstuk dubbelklik welke ik wil openen krijg ik de volgende foutmelding:

XML Parsing Error: no element found
Location: file:///C:/windows/temp/Temp.xml
Line Number 1, Column 1:


waarschijnlijk is het iets heel simpels, maar ik ben even lost hoe ik e.e.a aan de praat moet krijgen.
hier nog een screenshot van Furious, iets in me zegt dat daar een deel van het probleem zit

Afbeelding
Gebruikersavatar
MenthaSuaveolens
Junior
Junior
Berichten: 64
Lid geworden op: Vr 23 Mar 2018, 11:41

Re: Wine laat me in de steek

Berichtdoor MenthaSuaveolens » Zo 17 Nov 2019, 19:43

Ik ken Furious Mount niet, maar op Linux gaat het mounten van een cd of een cd-image vrij gemakkelijk. In eerste instantie zou ik van je cd proberen een schijfimage op je computer te maken. Die schijfimage zal een .iso extensie hebben. Je kan vervolgens die schij mouten vanuit je bestandenverkenner: Klik met de rechtermuisknop op het .iso-bestand, vervolgens openen met en Schijfkopiekoppelaar. Vervolgens start je wine op en zoek je met de Windows-verkenner naar de schijf. Klik op het .exe bestand. Ik vermoed dat je het programma dient uit te voeren in de map waarin de database staat.
rednasje
Nieuweling
Nieuweling
Berichten: 4
Lid geworden op: Di 05 Nov 2019, 20:50

Re: Wine laat me in de steek

Berichtdoor rednasje » Ma 18 Nov 2019, 16:49

De reden dat ik Furious gebruik is omdat je (volgens mij) vroeger een iso niet met Linux zelf kon koppelen, nu dus schijnbaar wel :)
Zo gezegd zo gedaan, de iso gekoppeld zoals je hebt voorgesteld.
Wine opstarten zegt me niks eigenlijk, ik rechtsklik op het exe bestand open het met WineWindows programmalader en dan opent het programma zich vanzelf.
Je laatste zin moet je me even uitleggen:Ik vermoed dat je het programma dient uit te voeren in de map waarin de database staat.
Moet ik nog iets aanpassen ?, hoe doe ik dit ?
Gebruikersavatar
MenthaSuaveolens
Junior
Junior
Berichten: 64
Lid geworden op: Vr 23 Mar 2018, 11:41

Re: Wine laat me in de steek

Berichtdoor MenthaSuaveolens » Ma 18 Nov 2019, 17:02

Ik vermoed dat er een verschil bestaat tussen het aanklikken van een .exe en het installeren van software dmw de Wine-installer. Als je Wine opent en je klikt op "Wine programma's verwijderen" (geen erg logische benaming, want je kan hiermee zowel programma's verwijderen als installeren), dan kan je hiermee een programma's installeren. Ik vermoed dat er tussen beide een verschil steekt. Welke instellingen heb je voor Wine gebruikt? (Welke Windows-versie?)
rednasje
Nieuweling
Nieuweling
Berichten: 4
Lid geworden op: Di 05 Nov 2019, 20:50

Re: Wine laat me in de steek

Berichtdoor rednasje » Ma 18 Nov 2019, 17:28

Wine stond op win10 ,nu op win7 en ook getest op Windows2003 maar het maakt geen verschil
Het gaat hier overigens niet om het installeren van software, enkel het uitlezen van de dvd (die ik opstart middels het exe bestand)
Als ik via Wine kies voor "installeren" (geen installatiebestand, die is er niet. dus ik kies voor exe bestand) krijg ik hetzelfde resultaat; de eerste vensters openen prima en ik kan bladeren naar de benodigde hoofdstukken,
maar openen van het hoofdstuk dat ik wil inzien geeft de bovenstaande foutmelding.
Gebruikersavatar
MenthaSuaveolens
Junior
Junior
Berichten: 64
Lid geworden op: Vr 23 Mar 2018, 11:41

Re: Wine laat me in de steek

Berichtdoor MenthaSuaveolens » Ma 18 Nov 2019, 18:16

Voor oudere programma's kies ik altijd WinXp. Wel ik vrees dat dat iet veel zal uithelpen. Blijkbaar wordt het bestand C:/windows/temp/Temp.xml niet aangemaakt. (Je eventueel gaan kijken wat er in dat bestand steekt). Ik leg altijd een snelkoppeling die ik Windows noem naar .wine/drive_c/ in home-folder. Heb je nagekeken of het programma wel geschikt is voor Wine? Je kan dat op de website van Wine nagaan en eventueel hints vinden hoe het werkende te krijgzn.
stegiman
Held
Held
Berichten: 324
Lid geworden op: Zo 17 Nov 2019, 15:12

Re: Wine laat me in de steek

Berichtdoor stegiman » Zo 08 Dec 2019, 15:06

Waarom doe je in wine terwijl het in Linux zelf kan.
Ik heb dat in Linux mint geïnstalleerd en werkt prima.
Zou het niet kunnen dat xml niet op de iso bevindt?
Anders kan het zijn dat je xml parser nog moet toevoegen.

Open eens Temp.xml met tekstverwerker en kijk wat op de eerst lijn staat.
c:\ bestaat niet in Linux en dus denk ik dat je wine niet moet openen.
Mogelijk moet je .xml locatie aanpassen.

Je open furios in Linux en dan iso koppelen en naar verkenner gaan en vandaar uit kan je in de iso bestanden gaan.
Doe je dat zo?
Gebruikersavatar
Joan
LMNLVip
LMNLVip
Berichten: 2799
Lid geworden op: Do 16 Feb 2012, 00:49
Contact:

Re: Wine laat me in de steek

Berichtdoor Joan » Zo 08 Dec 2019, 17:23

Zoals stegiman aangeeft is er geen c:\ in Linux, daardoor verschijnt de melding 'Location: file:///C:/windows/temp/Temp.xml'.
Wine heb ik niet en kan daarom niet controleren of daarin een c/ wordt aangemaakt.
Wil je een duidelijk antwoord? Stel dan een duidelijke vraag. , Kijk hoe dat moet bij Tips voor forumberichten.
Wil je een afbeelding plaatsen?. Kijk hoe dat kan bij Tip voor het plaatsen van afbeeldingen.
Wilfried1954
Algemene moderator
Algemene moderator
Berichten: 1218
Lid geworden op: Ma 08 Dec 2014, 11:26
Contact:

Re: Wine laat me in de steek

Berichtdoor Wilfried1954 » Do 02 Jan 2020, 08:18

Het hebt een ISO bestand gemound. Daar zou het probleem kunnen zitten. Ik denk dat je gewoon de uitvoerbare bestanden en de data op de cd moet zetten. Mounten gaat normaal gezien automatisch van als je de cd erin steekt.

Misschien eerst dat bestand in drive c:. Als je in een terminal venster iniikt: winecfg dan zie je welke drives toegewezen zijn en waar ze staan. Bij mij is dat /home/wilfried/.wine/drive_c/

Je kan ook eens proberen de bestanden gewoon in die folder (een subfolder eventueel) copieren en kijken of je ze daar kan uitvoeren. Maar ik weet niet zeker of dit met een iso bestand gaat.

Ik heb veel windows programma's en nog nooit een probleem ondervonden.

Terug naar “Software en applicaties”

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers en 8 gasten