Eid-belgium niet installeerbaar in verse Mint 20.1

Vragen over software en applicaties
Gebruikersavatar
emvedeesje
Held
Held
Berichten: 417
Lid geworden op: Zo 17 Jun 2018, 11:03
Locatie: Aalter-Ovl-Belgie

Eid-belgium niet installeerbaar in verse Mint 20.1

Berichtdoor emvedeesje » Di 12 Jan 2021, 12:01

eid-viewer
Als je in synaptic de eid-viewer aanduidt om te installeren, krijg je een bericht:
libcurl3 is not installable
libssl1.0.0 is not installable
libeidviewer0 zal niet worden geïnstalleerd
(in feite zijn libcurl3 en libssl1.0.0 wél reeds geïnstalleerd)

Oplossing
1- Sluit synaptic.
2- Ga naar Systeeminstellingen / Beheer / Pakketbronnen
Bij de Extra pakketbronnen staan 2 foutieve noteringen als Belgium / xenial
Selecteer de eerste en
*klik Bewerken.
*Vervang enkel het woord xenial door ulyana, en OK.
*Druk onderaan Oké om de bestandenlijst bij te werken.
Doe net hetzelfde voor de tweede.
3- Terminal

Code: Selecteer alles

sudo apt-get upgrade
4- Synaptic
Markeer en installeer eid-viewer
Mint cinnamon fan
Mint cinnamon -20.1 (komend van Mint-19 Mint-18 Mint-17 Ubuntu-16 Ubuntu-14 Ubuntu-12)
Gebruikersavatar
emvedeesje
Held
Held
Berichten: 417
Lid geworden op: Zo 17 Jun 2018, 11:03
Locatie: Aalter-Ovl-Belgie

Re: Eid-belgium niet installeerbaar in verse Mint 20.1

Berichtdoor emvedeesje » Di 12 Jan 2021, 18:05

Natuurlijk is dit ook nodig:

Code: Selecteer alles

sudo apt-get update
en pas dan :

Code: Selecteer alles

sudo apt-get upgrade
Mint cinnamon fan
Mint cinnamon -20.1 (komend van Mint-19 Mint-18 Mint-17 Ubuntu-16 Ubuntu-14 Ubuntu-12)
tytsjerksteradiel
Senior
Senior
Berichten: 286
Lid geworden op: Ma 16 Dec 2019, 01:16

Re: Eid-belgium niet installeerbaar in verse Mint 20.1

Berichtdoor tytsjerksteradiel » Di 12 Jan 2021, 22:30

Als het mij toegestaan is van hieraan toe te voegen ?

1/ vermeldenswaardig is dat bij een upgrade binnen 20.0 naar 20.1 het probleem zich niet stelt ( heb ik uitgetest )

2/ nieuw is inderdaad zo dat bij een VERSE installatie van Linux Mint 20e.1 r iets fout gaat met de installatie v/d Eid software, cq Eid kaartlezer door het feit dat de distro (bron)pakketten ophaalt die al lang niet meer ondersteund worden , namelijk Xenial … ?

dit heb ik nog nooit meegemaakt .

3/ een dot upgrade ( bvb van 19.0 naar 19.1 t.e.m 19.3 ) heeft in het verleden nooit problemen opgeleverd ?

een precedent dat ik helaas niet kan verklaren , dit probleem zal waarschijnlijk opgelost geraken van zodra de aangepaste .deb pakketten voor Ulyssa beschikbaar zullen zijn op de site ?

Zeker op te volgen
LMDE 4 Debbie Cinnamon
Debian 10.8 Buster stable Cinnamon
APT opdrachten : https://itsfoss.com/apt-command-guide/
apt versus apt-get : https://itsfoss.com/apt-vs-apt-get-difference/
tytsjerksteradiel
Senior
Senior
Berichten: 286
Lid geworden op: Ma 16 Dec 2019, 01:16

Re: Eid-belgium niet installeerbaar in verse Mint 20.1

Berichtdoor tytsjerksteradiel » Wo 13 Jan 2021, 07:05

......
een precedent dat ik helaas niet kan verklaren , dit probleem zal waarschijnlijk opgelost geraken van zodra de aangepaste .deb pakketten voor Ulyssa beschikbaar zullen zijn op de site ?
kan best zijn dat het niets te maken heeft met de .deb pakketten ( deze zijn tot nu toe nooit " dot " gebonden geweest ) , en dan is het een zuiver " verse installatieprobleem Linux MINT 20.1 probleem ...

wait en see of updates dit zal verhelpen ?
LMDE 4 Debbie Cinnamon
Debian 10.8 Buster stable Cinnamon
APT opdrachten : https://itsfoss.com/apt-command-guide/
apt versus apt-get : https://itsfoss.com/apt-vs-apt-get-difference/
Gebruikersavatar
emvedeesje
Held
Held
Berichten: 417
Lid geworden op: Zo 17 Jun 2018, 11:03
Locatie: Aalter-Ovl-Belgie

Re: Eid-belgium niet installeerbaar in verse Mint 20.1

Berichtdoor emvedeesje » Wo 13 Jan 2021, 09:33

Als het mij toegestaan is van hieraan toe te voegen ?

1/ vermeldenswaardig is dat bij een upgrade binnen 20.0 naar 20.1 het probleem zich niet stelt ( heb ik uitgetest )

2/ nieuw is inderdaad zo dat bij een VERSE installatie van Linux Mint 20e.1 r iets fout gaat met de installatie v/d Eid software, cq Eid kaartlezer door het feit dat de distro (bron)pakketten ophaalt die al lang niet meer ondersteund worden , namelijk Xenial … ?

dit heb ik nog nooit meegemaakt .

3/ een dot upgrade ( bvb van 19.0 naar 19.1 t.e.m 19.3 ) heeft in het verleden nooit problemen opgeleverd ?

een precedent dat ik helaas niet kan verklaren , dit probleem zal waarschijnlijk opgelost geraken van zodra de aangepaste .deb pakketten voor Ulyssa beschikbaar zullen zijn op de site ?

Zeker op te volgen
1/ dat heb ik ook gezien
2/ zelfde besluit
3/ ik ben steeds zeer argwanend als een andere versie, of een nieuwe kernel uitkomt.

Als je dan zo ver bent dat de eid-viewer werkt, werkt het ook in Firefox.
Voor Chrome moet je nog een speciale procedure doorlopen: https://eid.belgium.be/nl/aanmelden-met-eid#7311
En ook hier gaat het fout: zowel in de verse 20.1, als op de testbak waar de 20 > 20.1 upgrade gemaakt werd.

Code: Selecteer alles

modutil -dbdir sql:.pki/nssdb -add "Belgium eID" -libfile /usr/lib/x86_64-linux-gnu/libbeidpkcs11.so
WARNING: Performing this operation while the browser is running could cause
corruption of your security databases. If the browser is currently running,
you should exit browser before continuing this operation. Type
'q <enter>' to abort, or <enter> to continue:

*ERROR: Failed to add module "Belgium eID". Probable cause : "Failure to
load dynamic library".*
En daar stopt het.

Ik werk verder met de 19.3 en laat de volledige 20-reeks aan mij passeren.

groeten van Michael
Mint cinnamon fan
Mint cinnamon -20.1 (komend van Mint-19 Mint-18 Mint-17 Ubuntu-16 Ubuntu-14 Ubuntu-12)
tytsjerksteradiel
Senior
Senior
Berichten: 286
Lid geworden op: Ma 16 Dec 2019, 01:16

Re: Eid-belgium niet installeerbaar in verse Mint 20.1

Berichtdoor tytsjerksteradiel » Wo 13 Jan 2021, 10:41

...
Ik werk verder met de 19.3 en laat de volledige 20-reeks aan mij passeren.
Het is inderdaad zo dat U nog tijd zat hebt ( Linux Mint 19.x wordt ondersteund tot april 2023 ) om over te schakelen naar de laatste nieuwe “ punt “ uitgave .

Maar begrijp niet dat U als “ Mint Cinnamon fan “ en voortgaand op uw signatuur niet gewoonweg Linux Mint 20.0 in huis neemt ?

Voor zover natuurlijk dat U niet wakker ligt van Hypnotix ( als ik TV kijk werk ik niet op de computer en omgekeerd ) , de laatste desktop spitsvondigheden ( geen commentaar ) & Cinnamon 4.8 ( ben best tevreden met 4.6 ) … met alle respect voor al wie hier wel interesse voor heeft .

Voor mij stopt het los van het OS , dat het nu Linux Mint , LMDE of Debian weze van zodra ik de Eid software cq Eid viewer niet meer op een normale manier aan de praat zou krijgen … is zo al omslachtig genoeg … onze laptops zijn werkinstrumenten en wij zijn belg .
LMDE 4 Debbie Cinnamon
Debian 10.8 Buster stable Cinnamon
APT opdrachten : https://itsfoss.com/apt-command-guide/
apt versus apt-get : https://itsfoss.com/apt-vs-apt-get-difference/
seghele
Junior
Junior
Berichten: 41
Lid geworden op: Zo 26 Okt 2014, 16:36

Re: Eid-belgium niet installeerbaar in verse Mint 20.1

Berichtdoor seghele » Wo 13 Jan 2021, 12:43

Heb ook het probleem met een nieuwe installatie van Mint 20.1 Cinnamon.
EID (België) werkt niet!
Error:Er ontbreken diverse bestanden!
Blijkbaar heeft men enkele nodige bestanden niet opgenomen in 20.1, of niet ???
Misschien kan er iemand de makers van Mint (Ierland) op de hoogte brengen!
::)
Gebruikersavatar
emvedeesje
Held
Held
Berichten: 417
Lid geworden op: Zo 17 Jun 2018, 11:03
Locatie: Aalter-Ovl-Belgie

Re: Eid-belgium niet installeerbaar in verse Mint 20.1

Berichtdoor emvedeesje » Wo 13 Jan 2021, 17:07

@seghele
Het is opgelost als je het doet zoals in de eerste post.
En dan kan je draaien via FireFox.
Doch als je Chrome wilt gebruiken moet er nog wat meer geïnstalleerd worden: https://eid.belgium.be/nl/aanmelden-met-eid#7311
Maar dat loopt verkeerd af:
*ERROR: Failed to add module "Belgium eID". Probable cause : "Failure to load dynamic library".*

En dat doet zich hier voor op 2 totaal verschillende computers.

Ik ben daarover bezig met de helpdesk van BEID, doch zoals zo dikwijls lezen ze maar een deel en doen ze je dingen doen die je allang zelf geprobeerd hebt.
En uiteindelijk komen we weer bij start en gaan we terug rond met dezelfde probeersels.
Waarschijnlijk om tijd te rekken omdat ze ondertussen wel zien dat er wel degelijk iets fout is.

groeten van Michael
Mint cinnamon fan
Mint cinnamon -20.1 (komend van Mint-19 Mint-18 Mint-17 Ubuntu-16 Ubuntu-14 Ubuntu-12)
tytsjerksteradiel
Senior
Senior
Berichten: 286
Lid geworden op: Ma 16 Dec 2019, 01:16

Re: Eid-belgium niet installeerbaar in verse Mint 20.1

Berichtdoor tytsjerksteradiel » Do 14 Jan 2021, 04:04

eid-viewer
Als je in synaptic de eid-viewer aanduidt om te installeren, krijg je een bericht:
libcurl3 is not installable
libssl1.0.0 is not installable
libeidviewer0 zal niet worden geïnstalleerd

(in feite zijn libcurl3 en libssl1.0.0 wél reeds geïnstalleerd)
het enige verschil dat ik zie tussen een upgrade van 20.0 naar 20.1 en een verse installatie is dat
als U de update doet van 20.0 naar 20.1 , de convertering v/h systeem met usrmerge een optie is ( heb ik niet uitgevoerd ! )
Bij een verse installatie daarentegen gebeurt dit automatisch
Zie :
How to upgrade to Linux Mint 20.1
https://blog.linuxmint.com/?p=4020
4. Convert the system with usrmerge (optional)
Although it is optional we recommend you convert your system with usrmerge. This is done already for all fresh installations of Linux Mint 20.1.
For information on usrmerge, read https://www.freedesktop.org/wiki/Softwa ... eUsrMerge/.
To convert your system, open a terminal and type:
apt install usrmerge

Om terug te gaan naar :

libcurl3 is not installable
libssl1.0.0 is not installable
libeidviewer0 zal niet worden geïnstalleerd(in feite zijn libcurl3 en libssl1.0.0 wél reeds geïnstalleerd


en dan heb ik het over een upgrade van 20.0 naar 20.1 :
vind je deze pakketten wel , namelijk in de map usr/share/doc
maar , niet libssl1.0.0 , bij mij staat libssl1.1

misschien een usrmerge verhaal ?

ps : na de upgrade werkte mijn eID viewer nog steeds ... niets voor hoeven te doen
LMDE 4 Debbie Cinnamon
Debian 10.8 Buster stable Cinnamon
APT opdrachten : https://itsfoss.com/apt-command-guide/
apt versus apt-get : https://itsfoss.com/apt-vs-apt-get-difference/
Gebruikersavatar
emvedeesje
Held
Held
Berichten: 417
Lid geworden op: Zo 17 Jun 2018, 11:03
Locatie: Aalter-Ovl-Belgie

Re: Eid-belgium niet installeerbaar in verse Mint 20.1

Berichtdoor emvedeesje » Do 14 Jan 2021, 10:32

@ tytsjerksteradiel

lees opnieuw post #1 van dit topic.
De workaround is: de PPA's aanpassen.
Voer deze post #1 uit.

Dan werkt eid-viewer en het inloggen via FireFox.
Maar inloggen via Chrome zal je nog niet lukken want daarvoor moet extra SW geïnstalleerd worden, en dat gaat fout.
Dat vindt je in een verdere post in ditzelfde topic.

groeten van Michael
Mint cinnamon fan
Mint cinnamon -20.1 (komend van Mint-19 Mint-18 Mint-17 Ubuntu-16 Ubuntu-14 Ubuntu-12)
tytsjerksteradiel
Senior
Senior
Berichten: 286
Lid geworden op: Ma 16 Dec 2019, 01:16

Re: Eid-belgium niet installeerbaar in verse Mint 20.1

Berichtdoor tytsjerksteradiel » Do 14 Jan 2021, 11:17

Het is het één of het ander ;

1/ ofwel deugt het Debian pakket “ eid-archive2020.4_all.deb niet , wat mij sterk zou verbazen gezien het wel werkt binnen een upgrade van 20.0 naar 20.1

2/ ofwel is er een fout geslopen in de ISO voor een verse installatie van 20.1

alle lof voor de moeite die Emvedeesje genomen heeft om dit alsnog op een onorthodoxe op te lossen , maar ik vind persoonlijk dat het niet aan ons , gewone gebruiker , is om dit op deze wijze aan te pakken ;

het is aan de ontwikkelaars van Linux Mint 20.1 of van het Eid softwarepakket om dit recht te zetten .
LMDE 4 Debbie Cinnamon
Debian 10.8 Buster stable Cinnamon
APT opdrachten : https://itsfoss.com/apt-command-guide/
apt versus apt-get : https://itsfoss.com/apt-vs-apt-get-difference/
seghele
Junior
Junior
Berichten: 41
Lid geworden op: Zo 26 Okt 2014, 16:36

Re: Eid-belgium niet installeerbaar in verse Mint 20.1

Berichtdoor seghele » Do 14 Jan 2021, 16:19

Eindelijk !!! e met dank aan dit forum.
Heb alles zoals in de eerste post uitgevoerd .... en het werkt prima.
:)
Het zou inderdaad beter zijn dat de programmeurs van Mint 20.1 op de hoogte zouden gebracht worden.
:idee:
Gebruikersavatar
emvedeesje
Held
Held
Berichten: 417
Lid geworden op: Zo 17 Jun 2018, 11:03
Locatie: Aalter-Ovl-Belgie

Re: Eid-belgium niet installeerbaar in verse Mint 20.1

Berichtdoor emvedeesje » Vr 15 Jan 2021, 10:42

Vandaag eindelijk vooruitgang !

Na herhaalde contacten + doorsturen van commentaren + resultaten komt net de melding binnen vanuit BOSA (eid-belgium software):

We zijn het probleem intern aan het bekijken. We houden u op de hoogte.

Het is toch eigenaardig dat men meerdere malen moet herhalen, plus alle mogelijke bewijzen uit de kast halen, vooraleer men je melding wil gaan bekijken.
Er komen vragen van:
- probeer eens dat (net hetzelfde wat je eigen gemeld had)
- welke type kaartlezer is het?
- is de juiste driver geïnstalleerd?
- welke processor?
- is er een virusscanner actief?
Waar je dan doodleuk kunt op antwoorden dat het probleem zich voordoet op 2 multiboot computers:
- waar zowel mint-19.3 als 20.1 op draait
- en dat de kaartlezer wel werkt in Mint-19.3
- dat de software voor Chrome wel werkt in 19.3
- en dat er 2 totaal verschillende processoren in het spel zijn
- er draait nergens een virusscanner
- er is nergens een extra stuurprogramma nodig geweest; niet in 19.3 noch in 20.1

Afwachten nu...

Het is eigenlijk een gewoonte geworden na een nieuwe release, of een nieuwe stap dat er wat fout gaat met de eid-software.
Uit mijn vroegere ervaringen zag ik bij een nieuwe versie steeds dat eid niet in orde was, en dat dit na een tijd pas geregeld werd.
Nu had ik 20 laten passeren en gewacht op 20.1
En dat is alweer fout gedacht.
Wat moeten we dan gaan doen? We hebben het nodig...
Een versie gaan bevriezen? Naar de volgende stappen niet upgraden?
Ik denk dat ik bij de 19.3 blijf zolang het kan en dan misschien rechtstreeks de dubbele sprong neem naar 21.
Langer werken en minder installatie miserie.


groeten van Michael
Mint cinnamon fan
Mint cinnamon -20.1 (komend van Mint-19 Mint-18 Mint-17 Ubuntu-16 Ubuntu-14 Ubuntu-12)
tytsjerksteradiel
Senior
Senior
Berichten: 286
Lid geworden op: Ma 16 Dec 2019, 01:16

Re: Eid-belgium niet installeerbaar in verse Mint 20.1

Berichtdoor tytsjerksteradiel » Vr 15 Jan 2021, 11:25

Vandaag eindelijk vooruitgang !
Vandaag eindelijk vooruitgang !
Het is eigenlijk een gewoonte geworden na een nieuwe release, of een nieuwe stap dat er wat fout gaat met de eid-software.
......
groeten van Michael
eigenlijk niet Michael , als je maar weet dat bij een punt release ( 18 >19>20 ) je moet wachten tot de .deb pakketten aangepast zijn , welke de laatste 2 pakketten zijn die ondersteund zijn staat duidelijk vermeld op de site ... je moet wel wat geduld hebben .
Je bent het met mij eens dat dit probleem zich binnen een dot release nooit gesteld heeft . ja toch ?
LMDE 4 Debbie Cinnamon
Debian 10.8 Buster stable Cinnamon
APT opdrachten : https://itsfoss.com/apt-command-guide/
apt versus apt-get : https://itsfoss.com/apt-vs-apt-get-difference/
Gebruikersavatar
mutse
Held
Held
Berichten: 429
Lid geworden op: Wo 31 Mei 2017, 12:47
Locatie: Regio Roeselare - België

Re: Eid-belgium niet installeerbaar in verse Mint 20.1

Berichtdoor mutse » Vr 15 Jan 2021, 14:57

@ Forumleden,

Inpikkend op wat er reeds geschreven is over de problemen met het niet-werken van de Eid-Belgium na een upgrade/update naar een hogere/nieuwe versie van het systeem (had daar in het verleden ook al problemen mee), gebruik ik Eid-Belgium al een hele tijd niet meer in LinuxMint (maar wél in een ander 'Linux-gestuurd besturingssysteem' -- waar dat probleem, dat zich hier manifesteert, zich niet voor doet ... Ik heb dat ook voor gehad toen ik nog met OpenSuse aan de slag was).

Hopelijk gaan ze bij BOSA eens beseffen dat er een Eid-Belgium applicatie wordt gemaakt die automatisch wordt opgewaardeerd wanneer er zich een nieuwe versie aandient/gemaakt wordt van LinuxMint (maar ja, Windows krijgt voorrang ...Linux is het achtergestelde besturingssysteem ... :-x ).
Vandaar ...

Mijn 2-cent.
Groet,
mutse.
Linux 'Rolling Release' Maté 64-bit

Terug naar “Software en applicaties”

Wie is er online

Gebruikers op dit forum: Geen geregistreerde gebruikers en 8 gasten